com.atlassian.plugin.osgi.container.OsgiContainerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • h3. Summary After installing or upgrading to Team Calendars 5.2.16 Team Calendars is disabled at startup h3. Steps to Reproduce # Install Confluence 5.7.x # Install Team Calendars 5.2.16 # Restart Confluence h3. Expected Results Team Calendars would be enabled with the other plugins at startup h3. Actual Results The below exception is thrown in the atlassian-confluence.log file: {noformat} 2015-08-04 17:20:38,171 WARN [localhost-startStop-1] [osgi.container.felix.FelixOsgiContainerManager] doLog Unable to resolve bundle 20: Unresolved constrai nt in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.active objects.external)(version>=0.22.2)) 2015-08-04 17:20:38,171 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPluginInstalledHelper] getRequiredPlugins Cannot determine required plugins, cannot resolve bundle 'com.atlassian.confluence.extra.team-calendars' 2015-08-04 17:20:41,147 WARN [localhost-startStop-1] [osgi.container.felix.FelixOsgiContainerManager] doLog Unable to resolve bundle 20: Unresolved constrai nt in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.active objects.external)(version>=0.22.2)) 2015-08-04 17:20:41,781 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugi n 'com.atlassian.confluence.extra.team-calendars' : Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20 .0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)). This error usually occurs when your plugin impo rts a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN 2015-08-04 17:20:41,782 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Unable to enable plugin 'com.atlassian.confluence.extra.t eam-calendars' 2015-08-04 17:20:41,783 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Because of this exception com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104) ... Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:456) ... 18 more 2015-08-04 17:20:41,784 ERROR [localhost-startStop-1] [atlassian.plugin.manager.PluginEnabler] actualEnable Unable to enable plugin com.atlassian.confluence.extra.team-calendars com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1199) ... Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)) {noformat} h3.Workaround 1 Uninstall Team Calendars 5.2.16 and install Team Calendars 5.2.13 h3.Workaround 2 Upgrade Confluence to higher than 5.8 h3. Workaround 3 In some cases the plugin can be enabled in the UI after the initial attempt to enable times out.
    via by Ann Worley [Atlassian],
  • h3. Summary After installing or upgrading to Team Calendars 5.2.16 Team Calendars is disabled at startup h3. Steps to Reproduce # Install Confluence 5.7.x # Install Team Calendars 5.2.16 # Restart Confluence h3. Expected Results Team Calendars would be enabled with the other plugins at startup h3. Actual Results The below exception is thrown in the atlassian-confluence.log file: {noformat} 2015-08-04 17:20:38,171 WARN [localhost-startStop-1] [osgi.container.felix.FelixOsgiContainerManager] doLog Unable to resolve bundle 20: Unresolved constrai nt in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.active objects.external)(version>=0.22.2)) 2015-08-04 17:20:38,171 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPluginInstalledHelper] getRequiredPlugins Cannot determine required plugins, cannot resolve bundle 'com.atlassian.confluence.extra.team-calendars' 2015-08-04 17:20:41,147 WARN [localhost-startStop-1] [osgi.container.felix.FelixOsgiContainerManager] doLog Unable to resolve bundle 20: Unresolved constrai nt in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.active objects.external)(version>=0.22.2)) 2015-08-04 17:20:41,781 ERROR [localhost-startStop-1] [plugin.osgi.factory.OsgiPlugin] enableInternal Detected an error (BundleException) enabling the plugi n 'com.atlassian.confluence.extra.team-calendars' : Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20 .0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)). This error usually occurs when your plugin impo rts a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see https://developer.atlassian.com/x/mQAN 2015-08-04 17:20:41,782 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Unable to enable plugin 'com.atlassian.confluence.extra.t eam-calendars' 2015-08-04 17:20:41,783 WARN [localhost-startStop-1] [atlassian.plugin.impl.AbstractPlugin] enable Because of this exception com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104) ... Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409) at org.apache.felix.framework.Felix.startBundle(Felix.java:1709) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905) at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:456) ... 18 more 2015-08-04 17:20:41,784 ERROR [localhost-startStop-1] [atlassian.plugin.manager.PluginEnabler] actualEnable Unable to enable plugin com.atlassian.confluence.extra.team-calendars com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:1199) ... Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.confluence.extra.team-calendars [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=com.atlassian.activeobjects.external)(version>=0.22.2)) {noformat} h3.Workaround 1 Uninstall Team Calendars 5.2.16 and install Team Calendars 5.2.13 h3.Workaround 2 Upgrade Confluence to higher than 5.8 h3. Workaround 3 In some cases the plugin can be enabled in the UI after the initial attempt to enable times out.
    via by Ann Worley [Atlassian],
  • This issue is related to a workaround from known bugs below: * https://jira.atlassian.com/browse/GHS-3525 * https://jira.atlassian.com/browse/JRA-25309 After implement workaround from bugs above (upgrade activeobjects-plugin-0.15.5.jar), the following warning shown in the log: {noformat} 2011-09-02 20:21:57,049 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: /home/vkgan/deployment/gan44/home/plugins/installed-plugins/plugin.6370356898626892984.jira-greenhopper-plugin-5.7.1.jar (1314965153000) created 2011-09-02 20:21:57,532 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: /home/vkgan/deployment/gan44/home/plugins/installed-plugins/plugin.8007164227669070204.activeobjects-plugin-0.15.5.jar (1314691313000) created 2011-09-02 20:21:59,412 main INFO [atlassian.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for uninstalled plugin 'com.atlassian.activeobjects.activeobjects-plugin': [com.pyxis.greenhopper.jira]. Disabling... 2011-09-02 20:21:59,413 main INFO [atlassian.plugin.manager.DefaultPluginManager] Disabling com.pyxis.greenhopper.jira 2011-09-02 20:21:59,502 main INFO [atlassian.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.activeobjects.activeobjects-plugin' to 'com.atlassian.activeobjects.activeobjects-plugin' 2011-09-02 20:21:59,502 main INFO [atlassian.plugin.manager.DefaultPluginManager] Disabling com.atlassian.activeobjects.activeobjects-plugin 2011-09-02 20:22:01,159 main INFO [atlassian.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for uninstalled plugin 'com.pyxis.greenhopper.jira': []. Disabling... 2011-09-02 20:22:01,159 main INFO [atlassian.plugin.manager.DefaultPluginManager] Updating plugin 'com.pyxis.greenhopper.jira' to 'com.pyxis.greenhopper.jira' 2011-09-02 20:22:01,304 main WARN [plugin.osgi.factory.OsgiPlugin] Unable to enable plugin 'com.pyxis.greenhopper.jira' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot enable the plugin 'com.pyxis.greenhopper.jira' when the bundle is not in the resolved or installed state: 1(65) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:415) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:61) at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:684) at com.atlassian.jira.ComponentManager.startPluginSystem(ComponentManager.java:243) at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:236) at com.atlassian.jira.ComponentManager.start(ComponentManager.java:221) ... 2011-09-02 20:22:01,305 main ERROR [atlassian.plugin.manager.PluginEnabler] Unable to enable plugin com.pyxis.greenhopper.jira com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot enable the plugin 'com.pyxis.greenhopper.jira' when the bundle is not in the resolved or installed state: 1(65) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:415) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) {noformat} *Finding* * Only happened after upgrade to GreenHopper 5.7.1. * Doesn't affect GreenHopper functionality * Downgraded to GreenHopper 5.7, the warning disappear.
    via by Voon Kiat Gan [Atlassian],
  • This issue is related to a workaround from known bugs below: * https://jira.atlassian.com/browse/GHS-3525 * https://jira.atlassian.com/browse/JRA-25309 After implement workaround from bugs above (upgrade activeobjects-plugin-0.15.5.jar), the following warning shown in the log: {noformat} 2011-09-02 20:21:57,049 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: /home/vkgan/deployment/gan44/home/plugins/installed-plugins/plugin.6370356898626892984.jira-greenhopper-plugin-5.7.1.jar (1314965153000) created 2011-09-02 20:21:57,532 main INFO [atlassian.plugin.loaders.ScanningPluginLoader] Plugin Unit: /home/vkgan/deployment/gan44/home/plugins/installed-plugins/plugin.8007164227669070204.activeobjects-plugin-0.15.5.jar (1314691313000) created 2011-09-02 20:21:59,412 main INFO [atlassian.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for uninstalled plugin 'com.atlassian.activeobjects.activeobjects-plugin': [com.pyxis.greenhopper.jira]. Disabling... 2011-09-02 20:21:59,413 main INFO [atlassian.plugin.manager.DefaultPluginManager] Disabling com.pyxis.greenhopper.jira 2011-09-02 20:21:59,502 main INFO [atlassian.plugin.manager.DefaultPluginManager] Updating plugin 'com.atlassian.activeobjects.activeobjects-plugin' to 'com.atlassian.activeobjects.activeobjects-plugin' 2011-09-02 20:21:59,502 main INFO [atlassian.plugin.manager.DefaultPluginManager] Disabling com.atlassian.activeobjects.activeobjects-plugin 2011-09-02 20:22:01,159 main INFO [atlassian.plugin.manager.DefaultPluginManager] Found dependent enabled plugins for uninstalled plugin 'com.pyxis.greenhopper.jira': []. Disabling... 2011-09-02 20:22:01,159 main INFO [atlassian.plugin.manager.DefaultPluginManager] Updating plugin 'com.pyxis.greenhopper.jira' to 'com.pyxis.greenhopper.jira' 2011-09-02 20:22:01,304 main WARN [plugin.osgi.factory.OsgiPlugin] Unable to enable plugin 'com.pyxis.greenhopper.jira' com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot enable the plugin 'com.pyxis.greenhopper.jira' when the bundle is not in the resolved or installed state: 1(65) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:415) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682) at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156) at com.atlassian.jira.plugin.JiraPluginManager.start(JiraPluginManager.java:61) at com.atlassian.jira.ComponentManager$PluginSystem.start(ComponentManager.java:684) at com.atlassian.jira.ComponentManager.startPluginSystem(ComponentManager.java:243) at com.atlassian.jira.ComponentManager.quickStart(ComponentManager.java:236) at com.atlassian.jira.ComponentManager.start(ComponentManager.java:221) ... 2011-09-02 20:22:01,305 main ERROR [atlassian.plugin.manager.PluginEnabler] Unable to enable plugin com.pyxis.greenhopper.jira com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot enable the plugin 'com.pyxis.greenhopper.jira' when the bundle is not in the resolved or installed state: 1(65) at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:415) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237) at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99) {noformat} *Finding* * Only happened after upgrade to GreenHopper 5.7.1. * Doesn't affect GreenHopper functionality * Downgraded to GreenHopper 5.7, the warning disappear.
    via by Voon Kiat Gan [Atlassian],
  • JJUPIN will not enable - Atlassian Answers
    via by Unknown author,
    • com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.confluence.extra.team-calendars at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:479) at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:310) at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:136) at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:104)
    No Bugmate found.