java.lang.NoClassDefFoundError

javax/faces/webapp/UIComponentTag

Samebug tips1

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web3879

  • javax/faces/webapp/UIComponentTag
  • via Oracle Community by 666705, 1 year ago
    javax/faces/webapp/UIComponentTag
  • via Icesoft by jinxed, 11 months ago
    javax/faces/webapp/UIComponentTag
  • Stack trace

    • java.lang.NoClassDefFoundError: javax/faces/webapp/UIComponentTag at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:620) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124) at weblogic.utils.classloaders.GenericClassLoader.defineClass(GenericClassLoader.java:338) at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:291) at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:259) at weblogic.utils.classloaders.ChangeAwareClassLoader.findClass(ChangeAwareClassLoader.java:54) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at java.lang.ClassLoader.loadClass(ClassLoader.java:251)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 2 months ago
    Unknown user
    Once, 10 months ago
    Unknown user
    Once, 11 months ago
    142 more bugmates