org.eclipse.swtbot.swt.finder.widgets.TimeoutException: Timeout after: 5000 ms.: The shell 'Java Type Hierarchy - SpringSource Tool Suite' did not activate

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via SpringSource Issue Tracker by Tomasz Zarna, 1 year ago
Timeout after: 5000 ms.: The shell 'Java Type Hierarchy - SpringSource Tool Suite' did not activate
via SpringSource Issue Tracker by Tomasz Zarna, 1 year ago
Timeout after: 5000 ms.: The shell 'Java Type Hierarchy - SpringSource Tool Suite' did not activate
via Stack Overflow by Ethon
, 2 years ago
Timeout after: 20000 ms.: The shell 'Info' did not activate
via Stack Overflow by Damien Chesneau
, 2 years ago
Timeout after: 30000 ms.: Waiting for job : Refresh Could not find the progress view
via GitHub by reprogrammer
, 1 year ago
Timeout after: 10000 ms.: Could not find auto complete proposal using matcher ANYTHING
via GitHub by ryanbrainard
, 1 year ago
Timeout after: 60000 ms.: Project did not appear in project explorer
org.eclipse.swtbot.swt.finder.widgets.TimeoutException: Timeout after: 5000 ms.: The shell 'Java Type Hierarchy - SpringSource Tool Suite' did not activate
at org.eclipse.swtbot.swt.finder.SWTBotFactory.waitUntil(SWTBotFactory.java:398)
at org.eclipse.swtbot.swt.finder.SWTBotFactory.waitUntil(SWTBotFactory.java:372)
at org.eclipse.swtbot.swt.finder.SWTBotFactory.waitUntil(SWTBotFactory.java:360)
at com.vmware.vfabric.ide.eclipse.tcserver.tests.ui.TcServerNewServerWizardUiTest.openPreferences(TcServerNewServerWizardUiTest.java:646)
at com.vmware.vfabric.ide.eclipse.tcserver.tests.ui.TcServerNewServerWizardUiTest.deleteAllRuntimeConfigurations(TcServerNewServerWizardUiTest.java:483)
at com.vmware.vfabric.ide.eclipse.tcserver.tests.ui.TcServerNewServerWizardUiTest.doServerCreationTest(TcServerNewServerWizardUiTest.java:147)
at com.vmware.vfabric.ide.eclipse.tcserver.tests.ui.TcServerNewServerWizardUiTest.testWithoutExistingServerWithExistingInstance(TcServerNewServerWizardUiTest.java:131)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at junit.framework.TestCase.runTest(TestCase.java:168)
at junit.framework.TestCase.runBare(TestCase.java:134)
at org.eclipse.swtbot.swt.finder.SWTBotTestCase.runBare(SWTBotTestCase.java:228)
at junit.framework.TestResult$1.protect(TestResult.java:110)
at junit.framework.TestResult.runProtected(TestResult.java:128)
at junit.framework.TestResult.run(TestResult.java:113)
at junit.framework.TestCase.run(TestCase.java:124)
at junit.framework.TestSuite.runTest(TestSuite.java:243)
at junit.framework.TestSuite.run(TestSuite.java:238)
at junit.framework.TestSuite.runTest(TestSuite.java:243)
at junit.framework.TestSuite.run(TestSuite.java:238)
at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:467)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:683)
at org.eclipse.swtbot.eclipse.core.RemotePluginTestRunner.main(RemotePluginTestRunner.java:64)
at org.eclipse.swtbot.eclipse.core.UITestApplication.runTests(UITestApplication.java:117)
at java.lang.Thread.run(Unknown Source)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.