java.lang.UnsupportedClassVersionError

Bad version number in .class file

Samebug tips4

Update "latest" to Java 8 on DockerHub.

This might be caused by and outdated version of Java, SonarQube now uses Java 8 as default. You might upgrade java or use an older version of SonarQube.

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web4785

  • via Coderanch by Oczek Oczkowy, 9 months ago
    Bad version number in .class file
  • via Coderanch by Rajeev Ravindran, 11 months ago
    Bad version number in .class file
  • via Coderanch by Dave Alvarado, 7 months ago
    Bad version number in .class file
  • Stack trace

    • java.lang.UnsupportedClassVersionError: Bad version number in .class file at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:620) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 9 months ago
    Unknown user
    Once, 11 months ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    201 more bugmates