java.lang.UnsatisfiedLinkError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Eclipse not run in Lubuntu?
    via Ask Ubuntu by verdana
    ,
  • GitHub comment 37#138505079
    via GitHub by rgwch
    ,
  • JRMC Startup
    via by 690392,
  • "android update sdk" on headless linux
    via Stack Overflow by focuser
    ,
    • java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: /media/leader/MyData/Download/LinuxApp/eclipse/configuration/org.eclipse.osgi/744/0/.cp/libswt-pi-gtk-4527.so: libXtst.so.6: cannot open shared object file: No such file or directory no swt-pi-gtk in java.library.path /home/leader/.swt/lib/linux/x86/libswt-pi-gtk-4527.so: libXtst.so.6: cannot open shared object file: No such file or directory Can't load library: /home/leader/.swt/lib/linux/x86/libswt-pi-gtk.so at org.eclipse.swt.internal.Library.loadLibrary(Library.java:327) at org.eclipse.swt.internal.Library.loadLibrary(Library.java:236) at org.eclipse.swt.internal.gtk.OS.<clinit>(OS.java:38) at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63) at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54) at org.eclipse.swt.widgets.Display.<clinit>(Display.java:134) at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:734) at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:162) at org.eclipse.ui.internal.ide.application.IDEApplication.createDisplay(IDEApplication.java:169) at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:111) at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134) at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380) at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:497) at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669) at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608) at org.eclipse.equinox.launcher.Main.run(Main.java:1515)

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    andyglickandyglick
    1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    4 more bugmates