java.lang.StackOverflowError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Hi! On Eclipse startup I always get 'An internal error occurred during: "Pydev code completion"'. Everything seems to work ok -- including code completion -- after I confirm the message, but it's quite annoying. Exception Stack Trace: java.lang.StackOverflowError at org.eclipse.core.runtime.Path.append(Path.java:235) at org.eclipse.core.internal.resources.Container.findMember(Container.java:76) at org.eclipse.core.internal.resources.Container.findMember(Container.java:69) at org.python.pydev.plugin.PydevPlugin.getLocation(PydevPlugin.java:314) at org.python.pydev.plugin.PydevPlugin.getLocationFromWorkspace(PydevPlugin.java:303) at org.python.pydev.plugin.PydevPlugin.getLocation(PydevPlugin.java:321) [the last 2 lines are repeated some dozen times] Session Data: java.version=1.5.0_04 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US Command-line arguments: -os linux -ws gtk -arch x86 On the console I see: thk@ishmael:~$ ./bin/eclipse/eclipse executing /usr/bin/python /home/thk/bin/eclipse/plugins/org.python.pydev_0.9.8/PySrc/pycompletionserver.py 54802 57684 afterCreateProcess connecting This is on Debian unstable and occurs also on Red Hat EL 4 WS running Eclipse 3.1 and PyDev 0.9.8. (The Eclipse installation is shared between both OS'es.) The problem also occured with PyDev 0.9.7 and, I think, 0.9.6. With 0.9.8 I also see a leftover python process running after I quit Eclipse. I have to kill that process manually. According to the news this should have been fixed, hasn't it? Thanks a lot, - Thomas
    via by Nobody/Anonymous,
  • Hi! On Eclipse startup I always get 'An internal error occurred during: "Pydev code completion"'. Everything seems to work ok -- including code completion -- after I confirm the message, but it's quite annoying. Exception Stack Trace: java.lang.StackOverflowError at org.eclipse.core.runtime.Path.append(Path.java:235) at org.eclipse.core.internal.resources.Container.findMember(Container.java:76) at org.eclipse.core.internal.resources.Container.findMember(Container.java:69) at org.python.pydev.plugin.PydevPlugin.getLocation(PydevPlugin.java:314) at org.python.pydev.plugin.PydevPlugin.getLocationFromWorkspace(PydevPlugin.java:303) at org.python.pydev.plugin.PydevPlugin.getLocation(PydevPlugin.java:321) [the last 2 lines are repeated some dozen times] Session Data: java.version=1.5.0_04 java.vendor=Sun Microsystems Inc. BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US Command-line arguments: -os linux -ws gtk -arch x86 On the console I see: thk@ishmael:~$ ./bin/eclipse/eclipse executing /usr/bin/python /home/thk/bin/eclipse/plugins/org.python.pydev_0.9.8/PySrc/pycompletionserver.py 54802 57684 afterCreateProcess connecting This is on Debian unstable and occurs also on Red Hat EL 4 WS running Eclipse 3.1 and PyDev 0.9.8. (The Eclipse installation is shared between both OS'es.) The problem also occured with PyDev 0.9.7 and, I think, 0.9.6. With 0.9.8 I also see a leftover python process running after I quit Eclipse. I have to kill that process manually. According to the news this should have been fixed, hasn't it? Thanks a lot, - Thomas
    via by Nobody/Anonymous,
    • java.lang.StackOverflowError at org.eclipse.core.runtime.Path.append(Path.java:235)
    No Bugmate found.