Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

  1. ,
    via Google Groups by Marcus Haebler

    Update "latest" to Java 8 on DockerHub.

  2. ,
    via Stack Overflow by ERJAN

    This exception occurs when using an older version of java. Mainly when trying to run a jar compiled with a newer Java version in an older Java version. We can avoid this issue by executing the jar in the same version which it was compiled.

Solutions on the web

via Stack Overflow by riccamini
, 1 year ago
org.apache.nifi.processor.Processor: Provider nifi.test.processors.PutHiveQL could not be instantiated
via GitHub by mkobit
, 2 years ago
org.apache.nifi.controller.repository.FlowFileSwapManager: Provider org.apache.nifi.controller.FileSystemSwapManager could not be instantiated
via Stack Overflow by Torsten
, 2 years ago
org.threeten.bp.zone.ZoneRulesProvider: Provider org.threeten.bp.zone.TzdbZoneRulesProvider could not be instantiated: org.threeten.bp.zone.ZoneRulesException: Unable to load TZDB time-zone rules: jar:file:/jenkins-home/workspace/Trunk/Project/build/project.jar!/org/threeten/bp/TZDB.dat
java.util.ServiceConfigurationError: org.apache.nifi.processor.Processor: Provider nifi.test.processors.PutHiveQL could not be instantiated at java.util.ServiceLoader.fail(ServiceLoader.java:224)[na:1.7.0_95] at java.util.ServiceLoader.access$100(ServiceLoader.java:181)[na:1.7.0_95] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:377)[na:1.7.0_95] at java.util.ServiceLoader$1.next(ServiceLoader.java:445)[na:1.7.0_95] at org.apache.nifi.nar.ExtensionManager.loadExtensions(ExtensionManager.java:107)[nifi-nar-utils-0.6.0.1.2.0.1-1.jar:0.6.0.1.2.0.1-1] at org.apache.nifi.nar.ExtensionManager.discoverExtensions(ExtensionManager.java:88)[nifi-nar-utils-0.6.0.1.2.0.1-1.jar:0.6.0.1.2.0.1-1] at org.apache.nifi.NiFi.<init>(NiFi.java:120)[nifi-runtime-0.6.0.1.2.0.1-1.jar:0.6.0.1.2.0.1-1] at org.apache.nifi.NiFi.main(NiFi.java:227)[nifi-runtime-0.6.0.1.2.0.1-1.jar:0.6.0.1.2.0.1-1]Caused by: java.lang.UnsupportedClassVersionError: org/apache/nifi/processor/util/StandardValidators : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method)[na:1.7.0_95] at java.lang.ClassLoader.defineClass(ClassLoader.java:800)[na:1.7.0_95] at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)[na:1.7.0_95] at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)[na:1.7.0_95] at java.net.URLClassLoader.access$100(URLClassLoader.java:71)[na:1.7.0_95] at java.net.URLClassLoader$1.run(URLClassLoader.java:361)[na:1.7.0_95] at java.net.URLClassLoader$1.run(URLClassLoader.java:355)[na:1.7.0_95] at java.security.AccessController.doPrivileged(Native Method)[na:1.7.0_95] at java.net.URLClassLoader.findClass(URLClassLoader.java:354)[na:1.7.0_95] at java.lang.ClassLoader.loadClass(ClassLoader.java:425)[na:1.7.0_95] at java.lang.ClassLoader.loadClass(ClassLoader.java:358)[na:1.7.0_95] at nifi.test.processors.PutHiveQL.<clinit>(PutHiveQL.java:73)[nifi-hiveQLProcessor-1.0-SNAPSHOT.nar-unpacked/:na] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)[na:1.7.0_95] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)[na:1.7.0_95] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)[na:1.7.0_95] at java.lang.reflect.Constructor.newInstance(Constructor.java:526)[na:1.7.0_95] at java.lang.Class.newInstance(Class.java:383)[na:1.7.0_95] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:373)[na:1.7.0_95] ... 5 more