java.lang.NoClassDefFoundError

Could not initialize class weblogic.protocol.ServerIdentityManager$Initializer at weblogic.protocol.ServerIdentityManager.findServerIdentity(ServerIden tityManager.java:64) at weblogic.protocol.URLManager.findAdministrationURL(URLManager.java:17 1) at weblogic.server.ServerLifeCycleRuntime.getLifeCycleOperationsRemote(S erverLifeCycleRuntime.java:689) at weblogic.t3.srvr.ServerRuntime.sendStateToAdminServer(ServerRuntime.j ava:420)

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web7793

  • via Oracle Community by 746841, 1 year ago
    (URLManager.java:17 1) at weblogic.server.ServerLifeCycleRuntime.getLifeCycleOperationsRemote(S erverLifeCycleRuntime.java:689) at weblogic.t3.srvr.ServerRuntime.sendStateToAdminServer(ServerRuntime.j ava:420)
  • via hivmr.com by Unknown author, 11 months ago
    Could not initialize class weblogic.protocol.ServerIdentityManager$Initializer
  • via Oracle Community by user9146549, 11 months ago
    Could not initialize class weblogic.protocol.ServerIdentityManager$Initializer
  • Stack trace

    • java.lang.NoClassDefFoundError: Could not initialize class weblogic.protocol.ServerIdentityManager$Initializer at weblogic.protocol.ServerIdentityManager.findServerIdentity(ServerIden tityManager.java:64) at weblogic.protocol.URLManager.findAdministrationURL(URLManager.java:17 1) at weblogic.server.ServerLifeCycleRuntime.getLifeCycleOperationsRemote(S erverLifeCycleRuntime.java:689) at weblogic.t3.srvr.ServerRuntime.sendStateToAdminServer(ServerRuntime.j ava:420) at weblogic.t3.srvr.ServerRuntime.updateRunState(ServerRuntime.java:406) at weblogic.t3.srvr.T3Srvr.setState(T3Srvr.java:181) at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:452) at weblogic.Server.main(Server.java:67)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.