java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • In advanced search, with JQL *"~!"* will thrown java.lang.NullPointerException with in the Log but return result. !2.PNG! In the logs:- {noformat} java.lang.NullPointerException at com.atlassian.jira.issue.search.searchers.transformer.AbstractSearchInputTransformer.validateParams(AbstractSearchInputTransformer.java:109) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.getValueResults(DefaultSearcherService.java:244) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.getSearchResults(DefaultSearcherService.java:178) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.searchWithJql(DefaultSearcherService.java:172) at com.atlassian.jira.plugin.issuenav.IssueNavAction.performSearch(IssueNavAction.java:716) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doNav(IssueNavAction.java:224) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doDefault(IssueNavAction.java:157) at sun.reflect.GeneratedMethodAccessor575.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70) at webwork.util.InjectionUtils.invoke(InjectionUtils.java:56) at webwork.action.ActionSupport.invokeCommand(ActionSupport.java:433) at webwork.action.ActionSupport.execute(ActionSupport.java:157) ...... {noformat} If the JQL with "~!" is saved as filter, the page is not accessible and thrown System Error Page. !3.PNG! !1.PNG!
    via by KhongMing KOK [Atlassian],
  • In advanced search, with JQL *"~!"* will thrown java.lang.NullPointerException with in the Log but return result. !2.PNG! In the logs:- {noformat} java.lang.NullPointerException at com.atlassian.jira.issue.search.searchers.transformer.AbstractSearchInputTransformer.validateParams(AbstractSearchInputTransformer.java:109) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.getValueResults(DefaultSearcherService.java:244) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.getSearchResults(DefaultSearcherService.java:178) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.searchWithJql(DefaultSearcherService.java:172) at com.atlassian.jira.plugin.issuenav.IssueNavAction.performSearch(IssueNavAction.java:716) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doNav(IssueNavAction.java:224) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doDefault(IssueNavAction.java:157) at sun.reflect.GeneratedMethodAccessor575.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70) at webwork.util.InjectionUtils.invoke(InjectionUtils.java:56) at webwork.action.ActionSupport.invokeCommand(ActionSupport.java:433) at webwork.action.ActionSupport.execute(ActionSupport.java:157) ...... {noformat} If the JQL with "~!" is saved as filter, the page is not accessible and thrown System Error Page. !3.PNG! !1.PNG!
    via by KhongMing KOK [Atlassian],
  • So, in my plugin, I use the IssueService.create() method to add issues to a newly created project. This is the method I used to create them : IssueInputParameters issueToCreate = ComponentAccessor.getIssueService().newIssueInputParameters(); issueToCreate.set...; //All the sets IssueService.CreateValidationResult validationResult = ComponentAccessor.getIssueService().validateCreate(user, issueToCreate); if (validationResult.isValid()) { IssueService.IssueResult createdIssue = ComponentAccessor.getIssueService().create(user, validationResult); } When I do so, all the issues seems to be added correctly (I see all of them in the project page), but when I click on one, I get this error in the console : SEVERE: Servlet.service() for servlet action threw exception java.lang.NullPointerException at com.atlassian.jira.plugin.issuenav.action.IssueBean$IssueProjectBean.<init>(IssueBean.java:146) at com.atlassian.jira.plugin.issuenav.action.IssueBean.<init>(IssueBean.java:60) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doIssue(IssueNavAction.java:629) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doDefault(IssueNavAction.java:261) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70) [...] This is quit annoying since everywhere I look this is the method to use to create issues in a JIRA plugin (without using the REST API). Is this a known bug?
    via by Frederick Plante,
  • So, in my plugin, I use the IssueService.create() method to add issues to a newly created project. This is the method I used to create them : IssueInputParameters issueToCreate = ComponentAccessor.getIssueService().newIssueInputParameters(); issueToCreate.set...; //All the sets IssueService.CreateValidationResult validationResult = ComponentAccessor.getIssueService().validateCreate(user, issueToCreate); if (validationResult.isValid()) { IssueService.IssueResult createdIssue = ComponentAccessor.getIssueService().create(user, validationResult); } When I do so, all the issues seems to be added correctly (I see all of them in the project page), but when I click on one, I get this error in the console : SEVERE: Servlet.service() for servlet action threw exception java.lang.NullPointerException at com.atlassian.jira.plugin.issuenav.action.IssueBean$IssueProjectBean.<init>(IssueBean.java:146) at com.atlassian.jira.plugin.issuenav.action.IssueBean.<init>(IssueBean.java:60) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doIssue(IssueNavAction.java:629) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doDefault(IssueNavAction.java:261) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70) [...] This is quit annoying since everywhere I look this is the method to use to create issues in a JIRA plugin (without using the REST API). Is this a known bug?
    via by Frederick Plante,
    • java.lang.NullPointerException at com.atlassian.jira.issue.search.searchers.transformer.AbstractSearchInputTransformer.validateParams(AbstractSearchInputTransformer.java:109) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.getValueResults(DefaultSearcherService.java:244) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.getSearchResults(DefaultSearcherService.java:178) at com.atlassian.jira.plugin.issuenav.service.DefaultSearcherService.searchWithJql(DefaultSearcherService.java:172) at com.atlassian.jira.plugin.issuenav.IssueNavAction.performSearch(IssueNavAction.java:716) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doNav(IssueNavAction.java:224) at com.atlassian.jira.plugin.issuenav.IssueNavAction.doDefault(IssueNavAction.java:157) at sun.reflect.GeneratedMethodAccessor575.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) at java.lang.reflect.Method.invoke(Method.java:597) at webwork.util.InjectionUtils$DefaultInjectionImpl.invoke(InjectionUtils.java:70) at webwork.util.InjectionUtils.invoke(InjectionUtils.java:56) at webwork.action.ActionSupport.invokeCommand(ActionSupport.java:433) at webwork.action.ActionSupport.execute(ActionSupport.java:157)
    No Bugmate found.