java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • JSP Problem OC4J
    via by 431354,
  • JSP Problem OC4J
    via by 431354,
  • problems getting the demo running
    via by Jake Fear,
  • When publishing a fragment through CFragmentManager in uPortal 2.4 you can create a fragment and not enter a name or description and then return to the fragment manager the following NPE will happen. The code aparently writes a record with nulls for FRAGMENT_NAME and FRAGMENT_DESCRIPTION in UP_OWNER_FRAGMENT. Once this happens the fragment manager will always NPE until you remove this record from the database. Here are the steps to reproduce: 1. go to the fragment manager 2. click on create new fragment 3. click on submit properties 4. click on publish fragment java.lang.NullPointerException at java.util.Hashtable.put(Hashtable.java:393) at org.jasig.portal.layout.AggregatedUserLayoutStore.getFragments(AggregatedUserLayoutStore.java:1505) at org.jasig.portal.layout.AggregatedLayoutManager.getFragments(AggregatedLayoutManager.java:1154) at org.jasig.portal.layout.channels.CFragmentManager.getFragments(CFragmentManager.java:268) at org.jasig.portal.layout.channels.FragmentManager.refreshFragmentMap(FragmentManager.java:159) at org.jasig.portal.layout.channels.CFragmentManager.setPortalControlStructures(CFragmentManager.java:258) at org.jasig.portal.ChannelManager.processRequestChannelParameters(ChannelManager.java:853) at org.jasig.portal.ChannelManager.startRenderingCycle(ChannelManager.java:973) at org.jasig.portal.UserInstance.renderState(UserInstance.java:297) at org.jasig.portal.UserInstance.writeContent(UserInstance.java:205) at org.jasig.portal.PortalSessionManager.doGet(PortalSessionManager.java:271
    via by Brad Johnson,
  • Agent is down
    via by 575300,
  • odisrvreg fails when sslauth = 2
    via by Pete_Jibe,
  • startup
    via by 575300,
    • java.lang.NullPointerException at java.util.Hashtable.put(Hashtable.java:393) at oracle.lite.web.JupRequest.setAttribute(JupRequest.java:450) at oracle.lite.web.JupRequest.initURI(JupRequest.java:678) at oracle.lite.web.JupServlet.service(JupServlet.java:259) at oracle.lite.web.MimeServletHandler.handle(MimeServletHandler.java:100) at oracle.lite.web.JupApplication.service(JupApplication.java:525) at oracle.lite.web.JupHandler.handle(JupHandler.java:109) at oracle.lite.web.HTTPServer.process(HTTPServer.java:309) at oracle.lite.web.HTTPServer.include(HTTPServer.java:99) at oracle.jsp.runtime.OraclePageContext.include(OraclePageContext.java:514)

    Users with the same issue

    poroszdporoszd
    2 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    davidvanlaatumdavidvanlaatum
    1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    JustinJustin
    2 times, last one,
    19 more bugmates