org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • I tried to use Hibernate-Tools with the new Eclipse 3.3. I downloaded the current release of Eclipse 3.3 (June 25, 2007, eclipse-SDK-3.3-win32) and installed Hibernate-Tools 3.2beta9. After starting Eclipse I noticed that no Eclipse-Views of Hibernate-Tools are available, but the Hibernate plugin is visible under the 'Product Configuration' window. I have tried to manually start the org.eclipse.hibernate.mapper plugin with the osgi-console (I started eclipse with -console). I got the error message, that the org.eclipse.wst.xml plugin could not be located. 166 <<LAZY>> org.eclipse.wst.common.core_1.1.100.v200608220540 167 INSTALLED org.eclipse.wst.common.environment_1.0.100.v200608251934 168 INSTALLED org.eclipse.wst.common.frameworks_1.1.1.v200609132124 169 INSTALLED org.eclipse.wst.common.project.facet.core_1.1.1.v200608112156 170 INSTALLED org.eclipse.wst.common.project.facet.ui_1.1.1.v200608112156 171 <<LAZY>> org.eclipse.wst.common.ui_1.1.100.v200608221521 172 <<LAZY>> org.eclipse.wst.common.uriresolver_1.1.100.v200609200443 173 INSTALLED org.eclipse.wst.dtd.core_1.1.1.v200609210600 174 INSTALLED org.eclipse.wst.sse.core_1.1.100.v200609182120 175 INSTALLED org.eclipse.wst.sse.ui_1.0.200.v200609211325 176 INSTALLED org.eclipse.wst.validation_1.1.1.v200609132124 177 INSTALLED org.eclipse.wst.xml.core_1.1.1.v200609210600 178 RESOLVED org.apache.xerces_2.8.0.v200606131651 179 INSTALLED org.hibernate.eclipse.console_3.2.0.beta9a 180 ACTIVE org.hibernate.eclipse.help_3.2.0.beta9a 181 INSTALLED org.hibernate.eclipse.mapper_3.2.0.beta9a 182 ACTIVE org.hibernate.eclipse_3.2.0.beta9a 183 ACTIVE org.jboss.ide.eclipse.freemarker_1.0.0.Beta2 osgi> start org.hibernate.eclipse.mapper org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.wst.xml.core; bundle-version="0.0.0" at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:252) at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:260) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:145) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:291) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.console(FrameworkConsole.java:276) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:218) at java.lang.Thread.run(Unknown Source) osgi> So I downloaded the current wtp-package from the WTP Project Site (http://europa-mirror1.eclipse.org/webtools/downloads/drops/R2.0/R-2.0-200706260303/), installed it, and now it works.
    via by Christoph Mayerhofer,
  • I tried to use Hibernate-Tools with the new Eclipse 3.3. I downloaded the current release of Eclipse 3.3 (June 25, 2007, eclipse-SDK-3.3-win32) and installed Hibernate-Tools 3.2beta9. After starting Eclipse I noticed that no Eclipse-Views of Hibernate-Tools are available, but the Hibernate plugin is visible under the 'Product Configuration' window. I have tried to manually start the org.eclipse.hibernate.mapper plugin with the osgi-console (I started eclipse with -console). I got the error message, that the org.eclipse.wst.xml plugin could not be located. 166 <<LAZY>> org.eclipse.wst.common.core_1.1.100.v200608220540 167 INSTALLED org.eclipse.wst.common.environment_1.0.100.v200608251934 168 INSTALLED org.eclipse.wst.common.frameworks_1.1.1.v200609132124 169 INSTALLED org.eclipse.wst.common.project.facet.core_1.1.1.v200608112156 170 INSTALLED org.eclipse.wst.common.project.facet.ui_1.1.1.v200608112156 171 <<LAZY>> org.eclipse.wst.common.ui_1.1.100.v200608221521 172 <<LAZY>> org.eclipse.wst.common.uriresolver_1.1.100.v200609200443 173 INSTALLED org.eclipse.wst.dtd.core_1.1.1.v200609210600 174 INSTALLED org.eclipse.wst.sse.core_1.1.100.v200609182120 175 INSTALLED org.eclipse.wst.sse.ui_1.0.200.v200609211325 176 INSTALLED org.eclipse.wst.validation_1.1.1.v200609132124 177 INSTALLED org.eclipse.wst.xml.core_1.1.1.v200609210600 178 RESOLVED org.apache.xerces_2.8.0.v200606131651 179 INSTALLED org.hibernate.eclipse.console_3.2.0.beta9a 180 ACTIVE org.hibernate.eclipse.help_3.2.0.beta9a 181 INSTALLED org.hibernate.eclipse.mapper_3.2.0.beta9a 182 ACTIVE org.hibernate.eclipse_3.2.0.beta9a 183 ACTIVE org.jboss.ide.eclipse.freemarker_1.0.0.Beta2 osgi> start org.hibernate.eclipse.mapper org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.wst.xml.core; bundle-version="0.0.0" at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:252) at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:260) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:145) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:291) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.console(FrameworkConsole.java:276) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:218) at java.lang.Thread.run(Unknown Source) osgi> So I downloaded the current wtp-package from the WTP Project Site (http://europa-mirror1.eclipse.org/webtools/downloads/drops/R2.0/R-2.0-200706260303/), installed it, and now it works.
    via by Christoph Mayerhofer,
  • Using slf4j with jdk1.4
    via by amacg,
  • XBean spring-handler
    via by codymccain,
  • JamVM
    via by Andrew Peebles,
    • org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Require-Bundle: org.eclipse.wst.xml.core; bundle-version="0.0.0" at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:305) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260) at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:252) at org.eclipse.osgi.framework.internal.core.FrameworkCommandProvider._start(FrameworkCommandProvider.java:260) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.eclipse.osgi.framework.internal.core.FrameworkCommandInterpreter.execute(FrameworkCommandInterpreter.java:145) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.docommand(FrameworkConsole.java:291) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.console(FrameworkConsole.java:276) at org.eclipse.osgi.framework.internal.core.FrameworkConsole.run(FrameworkConsole.java:218) at java.lang.Thread.run(Unknown Source)

    Users with the same issue

    Unknown visitor
    Unknown visitor2 times, last one,