java.lang.ExceptionInInitializerError: This exception has no message.

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,

If JVM throws ClassNotFoundException the class is not found in classpath. Seems you are missing hibernate dependency in your project set up. Try downloading hibernate-core.jar and add to your project classpath.

Solutions on the web

via Liferay Issues by Jose Jimenez, 1 year ago
This exception has no message.
via Liferay Issues by Jose Jimenez, 1 year ago
This exception has no message.
via Apache's JIRA Issue Tracker by Yuri Schimke, 1 year ago
This exception has no message.
java.lang.ClassNotFoundException: org.apache.log4j.Category
at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:50)
at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:259)
at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:235)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:190)
at org.apache.commons.logging.impl.LogFactoryImpl.loadClass(LogFactoryImpl.java:435)
at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:376)
at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:529)
at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:235)
at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:209)
at org.apache.webdav.lib.WebdavSession.getSessionInstance(WebdavSession.java:145)
at org.apache.webdav.lib.WebdavSession.getSessionInstance(WebdavSession.java:127)
at org.apache.webdav.lib.WebdavResource.setClient(WebdavResource.java:1273)
at org.apache.webdav.lib.WebdavResource.setHttpURL(WebdavResource.java:1298)
at org.apache.webdav.lib.WebdavResource.setHttpURL(WebdavResource.java:1320)
at org.apache.webdav.lib.WebdavResource.setHttpURL(WebdavResource.java:1408)
at org.apache.webdav.lib.WebdavResource.(WebdavResource.java:290)
at org.apache.maven.wagon.providers.webdav.CorrectedWebdavResource.(CorrectedWebdavResource.java:54)
at org.eclipse.aether.connector.wagon.WagonRepositoryConnector.connectWagon(WagonRepositoryConnector.java:400)
at org.eclipse.aether.connector.wagon.WagonRepositoryConnector.pollWagon(WagonRepositoryConnector.java:440)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:724)

Users with the same issue

Once, 2 weeks ago
Once, 1 month ago
Once, 2 months ago
4 times, 5 months ago
2 times, 7 months ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.