java.lang.NoClassDefFoundError

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Problem with Tomcat 5 servlet-api.jar
    via strutstestcase by nobody
    ,
  • NoClassDef Error running examples.TestLoginAc
    via strutstestcase by nobody
    ,
  • org/apache/commons/validator/ValidatorResourc
    via strutstestcase by nobody
    ,
    • java.lang.NoClassDefFoundError: javax/servlet/jsp/JspException at org.apache.struts.util.MessageResourcesFactory.createFactory(MessageResourcesFactory.java:192) at org.apache.struts.util.MessageResources.getMessageResources(MessageResources.java:576) at org.apache.struts.action.ActionServlet.initInternal(ActionServlet.java:1329) at org.apache.struts.action.ActionServlet.init(ActionServlet.java:464) at javax.servlet.GenericServlet.init(GenericServlet.java:211) at servletunit.struts.MockStrutsTestCase.getActionServlet(MockStrutsTestCase.java:326) at strutsTutorial.UserRegistrationActionTest.setUp(UserRegistrationActionTest.java:31) at junit.framework.TestCase.runBare(TestCase.java:125) at junit.framework.TestResult$1.protect(TestResult.java:106) at junit.framework.TestResult.runProtected(TestResult.java:124) at junit.framework.TestResult.run(TestResult.java:109) at junit.framework.TestCase.run(TestCase.java:118) at junit.framework.TestSuite.runTest(TestSuite.java:208) at junit.framework.TestSuite.run(TestSuite.java:203) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:421) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:305) at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:186)
    No Bugmate found.