java.lang.NullPointerException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • After copying a previously run project to another location and importing the copied project, I am unable to launch the app and am greeted with the below error (also see screenshot attached). This is not a regression as I encounter the issue with Studio 3.4.1 as well. {code} An internal error occurred during: "Launching Appcelerator iOS Device - classiccopytest". java.lang.NullPointerException {code} *Steps to reproduce issue*: 1. Create a new default classic app 2. Run the app 3. Copy the project folder to a new location 4. Delete the existing project from Studio and import the copied project 5. Attempt to run the copied project 6. Notice the above error (see screenshot) *Expected Results*: Copied, imported project is able to run without error. *Notes*: Full error from log: {code} !ENTRY com.appcelerator.titanium.360.core 4 0 2015-02-23 12:24:11.736 !MESSAGE (Build 3.4.1.201410281743) [ERROR] Request: appCreateOrUpdate for project null and organization none !STACK 0 java.lang.NullPointerException at org.eclipse.core.runtime.Path.append(Path.java:261) at com.appcelerator.titanium.core.TitaniumProject.getIconPath(TitaniumProject.java:198) at com.appcelerator.titanium360.internal.core.ThreeSixtyProject.updateApp(ThreeSixtyProject.java:334) at com.appcelerator.titanium360.internal.core.Update360ProjectMetadataJob$3.run(Update360ProjectMetadataJob.java:196) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53) !ENTRY com.aptana.core 1 0 2015-02-23 12:24:11.739 !MESSAGE (Build 3.4.1.201410281743) [INFO] com.aptana.core/debug/shell Running process: Process: "/usr/local/bin/titanium" "--no-colors" "--no-progress-bars" "--no-prompt" "--no-banner" "status" "-o" "json" Working directory: null Environment: {ANALYTICS_SOURCE=studio, ANDROID_NDK=/Users/ewieber/Library/android-ndk-r8d, ANDROID_SDK=/Users/ewieber/Library/android-sdk-macosx, APTANA_VERSION=3.4.1.1413590581, Apple_PubSub_Socket_Render=/tmp/launch-wK5FbV/Render, HOME=/Users/ewieber, JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home, JENKINS_HOME=/Users/ewieber/Jenkins, LANG=en_US.UTF-8, LOGNAME=ewieber, PATH=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/local/share/npm/bin:/usr/local/git/bin:/opt/local/bin:/opt/local/sbin:/Users/ewieber/Library/android-sdk-macosx/platform-tools:/Users/ewieber/Library/android-sdk-macosx/tools:/Users/ewieber/apache-ant/bin, PWD=/Applications/Appcelerator_Studio/AppceleratorStudio.app/Contents/MacOS, SHELL=/bin/bash, SHLVL=1, SSH_AUTH_SOCK=/tmp/launch-PNHluC/Listeners, STUDIO_NAME=Appcelerator Studio, STUDIO_PRODUCT_ID=com.appcelerator.titanium.rcp.product, STUDIO_VERSION=3.4.1.201410281743, TMPDIR=/var/folders/v3/fx3x3sq94fngyrbcmtb9c1d40000gp/T/, USER=ewieber, __CF_USER_TEXT_ENCODING=0x1F6:0:0, __CHECKFIX1436934=1} !ENTRY org.eclipse.core.jobs 4 2 2015-02-23 12:24:12.418 !MESSAGE An internal error occurred during: "Launching Appcelerator iOS Device - anotherclassictest". !STACK 0 java.lang.NullPointerException at com.aptana.core.util.StringUtil.join(StringUtil.java:395) at com.aptana.core.util.StringUtil.join(StringUtil.java:300) at com.aptana.core.util.ProcessRunner.getObfuscatedCommandString(ProcessRunner.java:217) at com.aptana.core.util.ProcessRunner.doRun(ProcessRunner.java:140) at com.aptana.core.util.ProcessRunner.run(ProcessRunner.java:85) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.run(NodeTitaniumCLI.java:220) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.build(NodeTitaniumCLI.java:602) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.build(NodeTitaniumCLI.java:576) at com.appcelerator.titanium.ios.core.launching.IOSNodeJSCommandsHelper.build(IOSNodeJSCommandsHelper.java:273) at com.appcelerator.titanium.ios.core.launching.IOSNodeJSCommandsHelper.installOnDevice(IOSNodeJSCommandsHelper.java:125) at com.appcelerator.titanium.ios.internal.ui.launching.device.IOSInstallerLaunchConfigurationDelegate.launch(IOSInstallerLaunchConfigurationDelegate.java:112) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53) {code}
    via by Eric Wieber,
  • After copying a previously run project to another location and importing the copied project, I am unable to launch the app and am greeted with the below error (also see screenshot attached). This is not a regression as I encounter the issue with Studio 3.4.1 as well. {code} An internal error occurred during: "Launching Appcelerator iOS Device - classiccopytest". java.lang.NullPointerException {code} *Steps to reproduce issue*: 1. Create a new default classic app 2. Run the app 3. Copy the project folder to a new location 4. Delete the existing project from Studio and import the copied project 5. Attempt to run the copied project 6. Notice the above error (see screenshot) *Expected Results*: Copied, imported project is able to run without error. *Notes*: Full error from log: {code} !ENTRY com.appcelerator.titanium.360.core 4 0 2015-02-23 12:24:11.736 !MESSAGE (Build 3.4.1.201410281743) [ERROR] Request: appCreateOrUpdate for project null and organization none !STACK 0 java.lang.NullPointerException at org.eclipse.core.runtime.Path.append(Path.java:261) at com.appcelerator.titanium.core.TitaniumProject.getIconPath(TitaniumProject.java:198) at com.appcelerator.titanium360.internal.core.ThreeSixtyProject.updateApp(ThreeSixtyProject.java:334) at com.appcelerator.titanium360.internal.core.Update360ProjectMetadataJob$3.run(Update360ProjectMetadataJob.java:196) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53) !ENTRY com.aptana.core 1 0 2015-02-23 12:24:11.739 !MESSAGE (Build 3.4.1.201410281743) [INFO] com.aptana.core/debug/shell Running process: Process: "/usr/local/bin/titanium" "--no-colors" "--no-progress-bars" "--no-prompt" "--no-banner" "status" "-o" "json" Working directory: null Environment: {ANALYTICS_SOURCE=studio, ANDROID_NDK=/Users/ewieber/Library/android-ndk-r8d, ANDROID_SDK=/Users/ewieber/Library/android-sdk-macosx, APTANA_VERSION=3.4.1.1413590581, Apple_PubSub_Socket_Render=/tmp/launch-wK5FbV/Render, HOME=/Users/ewieber, JAVA_HOME=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home, JENKINS_HOME=/Users/ewieber/Jenkins, LANG=en_US.UTF-8, LOGNAME=ewieber, PATH=/Library/Java/JavaVirtualMachines/jdk1.7.0_45.jdk/Contents/Home/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/local/git/bin:/usr/local/share/npm/bin:/usr/local/git/bin:/opt/local/bin:/opt/local/sbin:/Users/ewieber/Library/android-sdk-macosx/platform-tools:/Users/ewieber/Library/android-sdk-macosx/tools:/Users/ewieber/apache-ant/bin, PWD=/Applications/Appcelerator_Studio/AppceleratorStudio.app/Contents/MacOS, SHELL=/bin/bash, SHLVL=1, SSH_AUTH_SOCK=/tmp/launch-PNHluC/Listeners, STUDIO_NAME=Appcelerator Studio, STUDIO_PRODUCT_ID=com.appcelerator.titanium.rcp.product, STUDIO_VERSION=3.4.1.201410281743, TMPDIR=/var/folders/v3/fx3x3sq94fngyrbcmtb9c1d40000gp/T/, USER=ewieber, __CF_USER_TEXT_ENCODING=0x1F6:0:0, __CHECKFIX1436934=1} !ENTRY org.eclipse.core.jobs 4 2 2015-02-23 12:24:12.418 !MESSAGE An internal error occurred during: "Launching Appcelerator iOS Device - anotherclassictest". !STACK 0 java.lang.NullPointerException at com.aptana.core.util.StringUtil.join(StringUtil.java:395) at com.aptana.core.util.StringUtil.join(StringUtil.java:300) at com.aptana.core.util.ProcessRunner.getObfuscatedCommandString(ProcessRunner.java:217) at com.aptana.core.util.ProcessRunner.doRun(ProcessRunner.java:140) at com.aptana.core.util.ProcessRunner.run(ProcessRunner.java:85) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.run(NodeTitaniumCLI.java:220) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.build(NodeTitaniumCLI.java:602) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.build(NodeTitaniumCLI.java:576) at com.appcelerator.titanium.ios.core.launching.IOSNodeJSCommandsHelper.build(IOSNodeJSCommandsHelper.java:273) at com.appcelerator.titanium.ios.core.launching.IOSNodeJSCommandsHelper.installOnDevice(IOSNodeJSCommandsHelper.java:125) at com.appcelerator.titanium.ios.internal.ui.launching.device.IOSInstallerLaunchConfigurationDelegate.launch(IOSInstallerLaunchConfigurationDelegate.java:112) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53) {code}
    via by Eric Wieber,
    • java.lang.NullPointerException at com.aptana.core.util.StringUtil.join(StringUtil.java:395) at com.aptana.core.util.StringUtil.join(StringUtil.java:300) at com.aptana.core.util.ProcessRunner.getObfuscatedCommandString(ProcessRunner.java:217) at com.aptana.core.util.ProcessRunner.doRun(ProcessRunner.java:140) at com.aptana.core.util.ProcessRunner.run(ProcessRunner.java:85) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.run(NodeTitaniumCLI.java:220) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.build(NodeTitaniumCLI.java:602) at com.appcelerator.titanium.core.internal.cli.NodeTitaniumCLI.build(NodeTitaniumCLI.java:576) at com.appcelerator.titanium.ios.core.launching.IOSNodeJSCommandsHelper.build(IOSNodeJSCommandsHelper.java:273) at com.appcelerator.titanium.ios.core.launching.IOSNodeJSCommandsHelper.installOnDevice(IOSNodeJSCommandsHelper.java:125) at com.appcelerator.titanium.ios.internal.ui.launching.device.IOSInstallerLaunchConfigurationDelegate.launch(IOSInstallerLaunchConfigurationDelegate.java:112) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:858) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:707) at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1018) at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1222) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
    No Bugmate found.