java.lang.UnsatisfiedLinkError

/Users/oracle/product/10.2.0/db\_1/lib/libocijdbc10.jnilib: no suitable image found. Did find: /Users/oracle/product/10.2.0/db\_1/lib/libocijdbc10.jnilib: mach-o, but wrong architecture /Users/oracle/product/10.2.0/db\_1/lib/libocijdbc10.jnilib: mach-o, but wrong architecture

Samebug tips1

This happens sometimes when Android fails to load the necessary libraries when you install an app. Try reinstalling it or telling your client to reinstall it, as it seems to correctly install the libraries and fixes the problem.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web5175

  • via schemaspy by jdanilson
    ,
  • via Stack Overflow by Poxipoler
    ,
  • Stack trace

    • java.lang.UnsatisfiedLinkError: /Users/oracle/product/10.2.0/db\_1/lib/libocijdbc10.jnilib: no suitable image found. Did find: /Users/oracle/product/10.2.0/db\_1/lib/libocijdbc10.jnilib: mach-o, but wrong architecture /Users/oracle/product/10.2.0/db\_1/lib/libocijdbc10.jnilib: mach-o, but wrong architecture at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1822) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1739) at java.lang.Runtime.loadLibrary0(Runtime.java:822) at java.lang.System.loadLibrary(System.java:993) at oracle.jdbc.driver.T2CConnection$1.run(T2CConnection.java:3146) at java.security.AccessController.doPrivileged(Native Method) at oracle.jdbc.driver.T2CConnection.loadNativeLibrary(T2CConnection.java:3142) at oracle.jdbc.driver.T2CConnection.logon(T2CConnection.java:220) at oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:440) at oracle.jdbc.driver.T2CConnection.<init>(T2CConnection.java:131) at oracle.jdbc.driver.T2CDriverExtension.getConnection(T2CDriverExtension.java:77) at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:752) at net.sourceforge.schemaspy.SchemaAnalyzer.getConnection(SchemaAnalyzer.java:481) at net.sourceforge.schemaspy.SchemaAnalyzer.analyze(SchemaAnalyzer.java:114) at net.sourceforge.schemaspy.Main.main(Main.java:21)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown visitor
    Unknown visitorOnce,
    Unknown UserUnknown User
    4 times, last one
    Unknown visitor
    Unknown visitorOnce,
    ReichReich
    2 times, last one
    Unknown visitor
    Unknown visitorOnce,
    298 more bugmates