com.mongodb.CommandFailureException

{ "serverUsed" : "/****" , "errmsg" : "auth fails" , "ok" : 0.0} { "serverUsed" : "****" , "errmsg" : "auth fails" , "ok" : 0.0}

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web64

  • via Pentaho BI Platform Tracking by Gregory, 1 year ago
    { "serverUsed" : "/****" , "errmsg" : "auth fails" , "ok" : 0.0}
  • via Pentaho BI Platform Tracking by Gregory, 1 year ago
    { "serverUsed" : "/****" , "errmsg" : "auth fails" , "ok" : 0.0}
  • via gmane.org by Unknown author, 1 year ago
    { "serverUsed" : "mymongohost/xx.xxx.xxx.xx:20000" , "ok" : 0.0 , "errmsg" : "auth fails"}
  • Stack trace

    • com.mongodb.CommandFailureException: { "serverUsed" : "/****" , "errmsg" : "auth fails" , "ok" : 0.0} { "serverUsed" : "****" , "errmsg" : "auth fails" , "ok" : 0.0} at org.pentaho.mongo.wrapper.UsernamePasswordMongoClientWrapper.getDb(UsernamePasswordMongoClientWrapper.java:95) at org.pentaho.mongo.wrapper.NoAuthMongoClientWrapper.getCollection(NoAuthMongoClientWrapper.java:1104) at org.pentaho.di.trans.steps.mongodbinput.MongoDbInput.init(MongoDbInput.java:248) at org.pentaho.di.trans.step.StepInitThread.run(StepInitThread.java:62) at java.lang.Thread.run(Thread.java:662) Caused by: com.mongodb.CommandFailureException: { "serverUsed" : "/****" , "errmsg" : "auth fails" , "ok" : 0.0} at com.mongodb.CommandResult.getException(CommandResult.java:71) at com.mongodb.CommandResult.throwOnError(CommandResult.java:110) at com.mongodb.DBPort$NativeAuthenticator.authenticate(DBPort.java:549) at com.mongodb.DBPort.authenticate(DBPort.java:322) at com.mongodb.DBTCPConnector.authenticate(DBTCPConnector.java:621) at com.mongodb.DBApiLayer.doAuthenticate(DBApiLayer.java:180) at com.mongodb.DB.authenticateCommandHelper(DB.java:630) at com.mongodb.DB.authenticateCommand(DB.java:609) at org.pentaho.mongo.wrapper.UsernamePasswordMongoClientWrapper.authenticateWithDb(UsernamePasswordMongoClientWrapper.java:101) at org.pentaho.mongo.wrapper.UsernamePasswordMongoClientWrapper.getDb(UsernamePasswordMongoClientWrapper.java:89) ... 4 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    3 times, 1 month ago
    Once, 2 months ago
    Unknown user
    4 times, 8 months ago
    Unknown user
    Once, 11 months ago
    Once, 1 year ago
    9 more bugmates