java.net.ConnectException: Connection refused: connect

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,

Check if your MongoDB is available.

,

Check if your MariaDB is running and available.

Solutions on the web

via Oracle Community by 843829, 1 year ago
Connection refused: connect
via Google Groups by bbking, 2 years ago
via Google Groups by Andreas Nordseth, 2 years ago
Connection refused: connect
via artima.com by Unknown author, 2 years ago
via Google Groups by Perry Sandoval, 3 months ago
Connection refused: connect
java.net.ConnectException: Connection refused: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:350)
at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:137)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:124)
at java.net.Socket.(Socket.java:268)
at java.net.Socket.(Socket.java:122)
at weblogic.net.http.HttpClient.openServer(HttpClient.java:201)
at weblogic.net.http.HttpClient.openServer(HttpClient.java:263)
at weblogic.net.http.HttpClient.(HttpClient.java:121)
at weblogic.net.http.HttpClient.New(HttpClient.java:156)
at weblogic.net.http.HttpURLConnection.connect(HttpURLConnection.java:111)
at weblogic.net.http.HttpURLConnection.getInputStream(HttpURLConnection.java:283)
at weblogic.j2ee.Component.getInputStream(Component.java:357)
at weblogic.j2ee.Component.retrieveComponent(Component.java:253)
at weblogic.j2ee.Component.(Component.java:162)
at weblogic.j2ee.WebAppComponent.(WebAppComponent.java:43)
at weblogic.j2ee.Application.addComponent(Application.java:145)
at weblogic.j2ee.J2EEService.addDeployment(J2EEService.java:117)
at weblogic.management.mbeans.custom.DeploymentTarget.addDeployment(DeploymentTarget.java:360)
at weblogic.management.mbeans.custom.DeploymentTarget.addDeployment(DeploymentTarget.java:150)
at weblogic.management.mbeans.custom.WebServer.addWebDeployment(WebServer.java:76)
at weblogic.management.internal.DynamicMBeanImpl.invokeLocally(DynamicMBeanImpl.java:636)
at weblogic.management.internal.DynamicMBeanImpl.invoke(DynamicMBeanImpl.java:621)
at weblogic.management.internal.ConfigurationMBeanImpl.invoke(ConfigurationMBeanImpl.java:360)
at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1557)
at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanServerImpl.java:1525)
at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:468)
at weblogic.management.internal.MBeanProxy.invoke(MBeanProxy.java:209)

Users with the same issue

11 times, 8 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
2 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
949 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.