java.lang.NoClassDefFoundError: com/sun/enterprise/deployment/archivist/MemoryMappedArchive

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

Solutions on the web

via Oracle Community by 807581, 1 year ago
com/sun/enterprise/deployment/archivist/MemoryMappedArchive
via Google Groups by ashi, 1 year ago
via Oracle Community by 843802, 1 year ago
com/sun/deploy/securi ty/DeployAuthenticator
via Oracle Community by 807606, 1 year ago
com/sun/deploy/securi ty/DeployAuthenticator
via wpthm.com by Unknown author, 2 years ago
com/sun/deploy/securi ty/DeployAuthenticator
via Stack Overflow by Daryl Spitzer
, 1 year ago
HelloWorld (wrong name: com/sun/jna/examples/HelloWorld)
java.lang.NoClassDefFoundError: com/sun/enterprise/deployment/archivist/MemoryMappedArchive
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
at com.sun.enterprise.tools.deployment.ui.DeployToolWindow.registerActions(DeployToolWindow.java:1272)
at com.sun.enterprise.tools.deployment.ui.DeployToolWindow.initialize(DeployToolWindow.java:280)
at com.sun.enterprise.tools.deployment.ui.DeployToolWindow.(DeployToolWindow.java:235)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
at java.lang.Class.newInstance0(Class.java:350)
at java.lang.Class.newInstance(Class.java:303)
at com.sun.enterprise.tools.deployment.ui.DT.startUI(DT.java:489)
at com.sun.enterprise.tools.deployment.ui.Main.startUI(Main.java:142)
at com.sun.enterprise.tools.deployment.ui.Main.main(Main.java:109)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 3 weeks ago
Samebug visitor profile picture
Unknown user
Once, 1 month ago
Once, 4 months ago
Once, 5 months ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.