java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.

opengts | bbct | 3 years ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    New Windows install generates error Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library

    opengts | 3 years ago | bbct
    java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.
  2. 0

    Where to specify jar file being used by OpenGTS to access SQL Server (sqljdbc4.jar)

    Stack Overflow | 3 years ago | Brian B
    java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0. at com.microsoft.sqlserver.jdbc.SQLServerConnection.<init>(SQLServerConnection.java:304)
  3. 0

    eclipse says it's using JRE 1.7 even though it's using 1.6

    Stack Overflow | 3 years ago | wjhplano
    java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Re: Error when importing data from sql server to sqoop

    sqoop-user | 1 year ago | Jarek Jarcec Cecho
    java.lang.RuntimeException: java.lang.RuntimeException: java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.
  6. 0

    RE: Error when importing data from sql server to sqoop

    sqoop-user | 1 year ago | Vishwakarma, Chhaya
    java.lang.RuntimeException: java.lang.RuntimeException: java.lang.UnsupportedOperationException: Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.

  1. Andreas Häber 2 times, last 4 months ago
1 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.UnsupportedOperationException

    Java Runtime Environment (JRE) version 1.7 is not supported by this driver. Use the sqljdbc4.jar class library, which provides support for JDBC 4.0.

    at com.microsoft.sqlserver.jdbc.SQLServerConnection.<init>()
  2. com.microsoft.sqlserver
    SQLServerDriver.connect
    1. com.microsoft.sqlserver.jdbc.SQLServerConnection.<init>(SQLServerConnection.java:304)
    2. com.microsoft.sqlserver.jdbc.SQLServerDriver.connect(SQLServerDriver.java:1011)
    2 frames
  3. Java RT
    DriverManager.getConnection
    1. java.sql.DriverManager.getConnection(Unknown Source)
    2. java.sql.DriverManager.getConnection(Unknown Source)
    2 frames
  4. org.opengts.dbtools
    DBFactory.tableExists
    1. org.opengts.dbtools.DBConnection.getConnection(DBConnection.java:659)
    2. org.opengts.dbtools.DBConnection.createStatement(DBConnection.java:769)
    3. org.opengts.dbtools.DBConnection._execute(DBConnection.java:856)
    4. org.opengts.dbtools.DBConnection.execute(DBConnection.java:811)
    5. org.opengts.dbtools.DBConnection.execute(DBConnection.java:793)
    6. org.opengts.dbtools.DBFactory.tableExists(DBFactory.java:1648)
    6 frames
  5. org.opengts.tools
    CheckInstall.main
    1. org.opengts.tools.CheckInstall.main(CheckInstall.java:2100)
    1 frame