org.openqa.selenium.firefox.NotConnectedException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Re: Issue 1181 in selenium: Firefox driver connection problem
    via by sele...@googlecode.com,
  • FireFox Profile Error
    via Stack Overflow by Mary
    ,
    • org.openqa.selenium.firefox.NotConnectedException: Unable to connect to host 127.0.0.1 on port 7055 after 45000 ms. Firefox console output: 0592358230 addons.xpi DEBUG Notifying XPI shutdown observers 1410592358233 addons.manager DEBUG Async provider shutdown done 1410592359047 addons.manager DEBUG Loaded provider scope for resource://gre/modules/addons/XPIProvider.jsm: ["XPIProvider"] 1410592359049 addons.manager DEBUG Loaded provider scope for resource://gre/modules/LightweightThemeManager.jsm: ["LightweightThemeManager"] 1410592359050 addons.xpi DEBUG startup 1410592359052 addons.xpi DEBUG Skipping unavailable install location app-system-local 1410592359052 addons.xpi DEBUG Skipping unavailable install location app-system-share 1410592359054 addons.xpi INFO Mapping {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A} to C:\Program Files\Mozilla Firefox\browser\extensions\{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi 1410592359054 addons.xpi INFO Mapping {972ce4c6-7e08-4474-a285-3208198ce6fd} to C:\Program Files\Mozilla Firefox\browser\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd} 1410592359055 addons.xpi INFO Mapping {e4f94d1e-2f53-401e-8885-681602c0ddd8} to C:\ProgramData\McAfee Security Scan\Extensions\{e4f94d1e-2f53-401e-8885-681602c0ddd8}.xpi 1410592359058 addons.xpi INFO Mapping fxdriver@googlecode.com to C:\Users\welcome\AppData\Local\Temp\anonymous5659030434610182700webdriver-profile\extensions\fxdriver@googlecode.com 1410592359058 addons.xpi DEBUG Ignoring file entry whose name is not a valid add-on ID: C:\Users\welcome\AppData\Local\Temp\anonymous5659030434610182700webdriver-profile\extensions\webdriver-staging 1410592359058 addons.xpi DEBUG checkForChanges 1410592359082 addons.xpi DEBUG No changes found 1410592359086 addons.xpi DEBUG Registering manifest for C:\Program Files\Mozilla Firefox\browser\extensions\{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi 1410592359086 addons.xpi DEBUG Loading bootstrap scope from C:\Program Files\Mozilla Firefox\browser\extensions\{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}.xpi 1410592359093 addons.xpi DEBUG Calling bootstrap method startup on {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A} version 7.3.16540.9015 *** Blocklist::_preloadBlocklistFile: blocklist is disabled console.error: skype_ff_extension: DEPRECATED: The widget module is deprecated. Please consider using the sdk/ui module instead. Traceback (most recent call last): File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 114, in startup/< run(options); File "resource://gre/modules/commonjs/sdk/addon/runner.js", line 170, in run let program = main(options.loader, options.main); File "resource://gre/modules/commonjs/toolkit/loader.js", line 645, in main return loader.load(loader, module).exports; File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 129, in CuddlefishLoader/options<.load result = load(loader, module); File "resource://gre/modules/commonjs/toolkit/loader.js", line 299, in load evaluate(sandbox, module.uri); File "resource://gre/modules/commonjs/toolkit/loader.js", line 262, in evaluate : loadSubScript(uri, sandbox, encoding); File "resource://skype_ff_extension-at-jetpack/skype_ff_extension/lib/main.js", line 14, in null var widgets = require("sdk/widget"); File "resource://gre/modules/commonjs/toolkit/loader.js", line 619, in require freeze(load(loader, module)); File "resource://gre/modules/commonjs/sdk/loader/cuddlefish.js", line 129, in CuddlefishLoader/options<.load result = load(loader, module); File "resource://gre/modules/commonjs/toolkit/loader.js", line 299, in load evaluate(sandbox, module.uri); File "resource://gre/modules/commonjs/toolkit/loader.js", line 262, in evaluate : loadSubScript(uri, sandbox, encoding); File "resource://gre/modules/commonjs/sdk/widget.js", line 60, in null "The widget module is deprecated. " + File "resource://gre/modules/commonjs/sdk/util/deprecate.js", line 18, in deprecateUsage let stack = get().slice(2); JavaScript error: resource://skype_ff_extension-at-jetpack/skype_ff_extension/data/c2c_options_menu_localization.js, line 189: document.getElementById(...) is null at org.openqa.selenium.firefox.internal.NewProfileExtensionConnection.start(NewProfileExtensionConnection.java:118) at org.openqa.selenium.firefox.FirefoxDriver.startClient(FirefoxDriver.java:246) at org.openqa.selenium.remote.RemoteWebDriver.<init>(RemoteWebDriver.java:114) at org.openqa.selenium.firefox.FirefoxDriver.<init>(FirefoxDriver.java:193) at org.openqa.selenium.firefox.FirefoxDriver.<init>(FirefoxDriver.java:186) at org.openqa.selenium.firefox.FirefoxDriver.<init>(FirefoxDriver.java:182) at org.openqa.selenium.firefox.FirefoxDriver.<init>(FirefoxDriver.java:95) at com.stta.SuiteOne.TakeSnapShot.main(TakeSnapShot.java:14)

    Users with the same issue

    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    71 more bugmates