java.lang.ClassCastException

org.apache.log4j.ConsoleAppender cannot be cast to org.apache.log4j.Appender

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web19025

  • org.apache.log4j.ConsoleAppender cannot be cast to org.apache.log4j.Appender
  • org.apache.log4j.ConsoleAppender cannot be cast to org.apache.log4j.Appender
  • org.apache.log4j.ConsoleAppender cannot be cast to org.apache.log4j.Appender
  • Stack trace

    • java.lang.ClassCastException: org.apache.log4j.ConsoleAppender cannot be cast to org.apache.log4j.Appender at org.apache.log4j.xml.DOMConfigurator.parseAppender(DOMConfigurator.java:175) at org.apache.log4j.xml.DOMConfigurator.findAppenderByName(DOMConfigurator.java:150) at org.apache.log4j.xml.DOMConfigurator.findAppenderByReference(DOMConfigurator.java:163) at org.apache.log4j.xml.DOMConfigurator.parseChildrenOfLoggerElement(DOMConfigurator.java:425) at org.apache.log4j.xml.DOMConfigurator.parseCategory(DOMConfigurator.java:345) at org.apache.log4j.xml.DOMConfigurator.parse(DOMConfigurator.java:827) at org.apache.log4j.xml.DOMConfigurator.doConfigure(DOMConfigurator.java:712) at org.apache.log4j.xml.DOMConfigurator.doConfigure(DOMConfigurator.java:618) at org.apache.log4j.xml.DOMConfigurator.configure(DOMConfigurator.java:743) at com.eviware.soapui.DefaultSoapUICore.initLog(DefaultSoapUICore.java:251) at com.eviware.soapui.DefaultSoapUICore.init(DefaultSoapUICore.java:78) at com.eviware.soapui.DefaultSoapUICore.<init>(DefaultSoapUICore.java:73) at com.eviware.soapui.SwingSoapUICore.<init>(SwingSoapUICore.java:42) at com.eviware.soapui.SwingPluginSoapUICore.<init>(SwingPluginSoapUICore.java:29) at com.eviware.soapui.SwingPluginSoapUICore.<init>(SwingPluginSoapUICore.java:24) at com.eviware.soapui.netbeans.module.Installer$1.<init>(Installer.java:196) at com.eviware.soapui.netbeans.module.Installer.initSoapUICore(Installer.java:193) at com.eviware.soapui.netbeans.module.Installer.restored(Installer.java:84) at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:419) at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:340) at org.netbeans.ModuleManager.enable(ModuleManager.java:936) at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:428) at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:364) at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:276) at org.netbeans.core.startup.Main.getModuleSystem(Main.java:174) at org.netbeans.core.startup.Main.start(Main.java:325) at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:110) at java.lang.Thread.run(Thread.java:619)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago