org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • Starting GlassFish 4.0 (build 60) with JDK 8 but gives the following errors: Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=192m; support was removed in 8.0 Launching GlassFish on Felix platform ERROR: Error parsing system bundle export statement: org.osgi.framework; version=1.6.0, org.osgi.framework.launch; version=1.0.0, org.osgi.framework.wiring; version=1.0.0, org.osgi.framework.startlevel; version=1.0.0, org.osgi.framework.hooks.bundle; version=1.0.0, org.osgi.framework.hooks.resolver; version=1.0.0, org.osgi.framework.hooks.service; version=1.1.0, org.osgi.framework.hooks.weaving; version=1.0.0, org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.startlevel; version=1.1.0, org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.5.0, , org.glassfish.embeddable;org.glassfish.embeddable.spi;version=3.1.1 (org.osgi.framework.BundleException: Exported package names cannot be zero length.) org.osgi.framework.BundleException: Exported package names cannot be zero length. at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeExportClauses(ManifestParser.java:729) at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:191) at org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.java:220) at org.apache.felix.framework.Felix.<init>(Felix.java:374) at org.apache.felix.framework.FrameworkFactory.newFramework(FrameworkFactory.java:28) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiFrameworkLauncher.launchOSGiFrameWork(OSGiFrameworkLauncher.java:77) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:129) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Oct 30, 2012 9:57:11 AM BundleProvisioner createBundleProvisioner INFO: clazz = class com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner Oct 30, 2012 9:57:11 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/flashlight-extra-jdk-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish-corba-omgapi.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish-extra-jre-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish-oracle-jdbc-driver-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/javax.transaction.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:13 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/webservices-extra-jdk-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more ERROR: Bundle jaxb-api [2] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/endorsed/jaxb-api-osgi.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle jaxb-api [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)) org.osgi.framework.BundleException: Unresolved constraint in bundle jaxb-api [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.metro.webservices-api-osgi [3] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/endorsed/webservices-api-osgi.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.metro.webservices-api-osgi [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.bind)(version>=2.2.0)) [caused by: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.metro.webservices-api-osgi [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.bind)(version>=2.2.0)) [caused by: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.osgi-resource-locator [4] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/osgi-resource-locator.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-resource-locator [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-resource-locator [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.asm-all-repackaged [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) ERROR: Bundle org.glassfish.hk2.external.asm-all-repackaged [18] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/asm-all-repackaged.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.asm-all-repackaged [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.external.bean-validator [20] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/bean-validator.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.bean-validator [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.script)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.bean-validator [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.script) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.external.cglib [21] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/cglib.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.cglib [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.cglib [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.config-types [36] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/config-types.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config-types [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (&(osgi.wiring.package=org.jvnet.hk2.annotations)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config-types [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (&(osgi.wiring.package=org.jvnet.hk2.annotations)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.core [67] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/core.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.core [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.core [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.main.core.glassfish [108] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish.jar (org.osgi.framework.BundleException: Activator start error in bundle org.glassfish.main.core.glassfish [108].) java.lang.NoClassDefFoundError: org/osgi/framework/BundleActivator at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:791) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2128) at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1432) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843) at java.lang.ClassLoader.loadClass(ClassLoader.java:356) at org.apache.felix.framework.BundleWiringImpl.getClassByDelegation(BundleWiringImpl.java:1317) at org.apache.felix.framework.Felix.createBundleActivator(Felix.java:4170) at org.apache.felix.framework.Felix.activateBundle(Felix.java:1972) at org.apache.felix.framework.Felix.startBundle(Felix.java:1895) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) Caused by: java.lang.ClassNotFoundException: org.osgi.framework.BundleActivator not found by org.glassfish.main.core.glassfish [108] at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843) at java.lang.ClassLoader.loadClass(ClassLoader.java:356) ... 14 more ERROR: Bundle org.glassfish.hk2.api [117] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-api.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.config [118] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-config.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config [118]: Unable to resolve 118.0: missing requirement [118.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.hk2.component)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 119.0: missing requirement [119.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config [118]: Unable to resolve 118.0: missing requirement [118.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.hk2.component)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 119.0: missing requirement [119.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.locator [120] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-locator.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.locator [120]: Unable to resolve 120.0: missing requirement [120.0] osgi.wiring.package; (osgi.wiring.package=net.sf.cglib.proxy) [caused by: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.locator [120]: Unable to resolve 120.0: missing requirement [120.0] osgi.wiring.package; (osgi.wiring.package=net.sf.cglib.proxy) [caused by: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.runlevel [121] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-runlevel.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.apache.felix.bundlerepository [202] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/org.apache.felix.bundlerepository.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.osgi-adapter [212] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/osgi-adapter.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) Exception in thread "main" java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: org.glassfish.embeddable.GlassFishException: org.glassfish.embeddable.GlassFishException: No GlassFishRuntime available at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:169) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) ... 6 more Caused by: org.glassfish.embeddable.GlassFishException: No GlassFishRuntime available at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.getGlassFishRuntime(OSGiGlassFishRuntimeBuilder.java:207) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:167) ... 9 more Error stopping framework: java.lang.NullPointerException java.lang.NullPointerException at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher$1.run(GlassFishMain.java:203) Command start-domain failed. The DAS was stopped. A similar error is also reported at: http://stackoverflow.com/questions/13139794/glassfish-server-does-not-work-with-jdk-8
    via by arungupta,
  • Starting GlassFish 4.0 (build 60) with JDK 8 but gives the following errors: Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=192m; support was removed in 8.0 Launching GlassFish on Felix platform ERROR: Error parsing system bundle export statement: org.osgi.framework; version=1.6.0, org.osgi.framework.launch; version=1.0.0, org.osgi.framework.wiring; version=1.0.0, org.osgi.framework.startlevel; version=1.0.0, org.osgi.framework.hooks.bundle; version=1.0.0, org.osgi.framework.hooks.resolver; version=1.0.0, org.osgi.framework.hooks.service; version=1.1.0, org.osgi.framework.hooks.weaving; version=1.0.0, org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.startlevel; version=1.1.0, org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.5.0, , org.glassfish.embeddable;org.glassfish.embeddable.spi;version=3.1.1 (org.osgi.framework.BundleException: Exported package names cannot be zero length.) org.osgi.framework.BundleException: Exported package names cannot be zero length. at org.apache.felix.framework.util.manifestparser.ManifestParser.normalizeExportClauses(ManifestParser.java:729) at org.apache.felix.framework.util.manifestparser.ManifestParser.<init>(ManifestParser.java:191) at org.apache.felix.framework.ExtensionManager.<init>(ExtensionManager.java:220) at org.apache.felix.framework.Felix.<init>(Felix.java:374) at org.apache.felix.framework.FrameworkFactory.newFramework(FrameworkFactory.java:28) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiFrameworkLauncher.launchOSGiFrameWork(OSGiFrameworkLauncher.java:77) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:129) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Oct 30, 2012 9:57:11 AM BundleProvisioner createBundleProvisioner INFO: clazz = class com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner Oct 30, 2012 9:57:11 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/flashlight-extra-jdk-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish-corba-omgapi.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish-extra-jre-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish-oracle-jdbc-driver-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:12 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/javax.transaction.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more Oct 30, 2012 9:57:13 AM BundleProvisioner install WARNING: Failed to install file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/webservices-extra-jdk-packages.jar org.osgi.framework.BundleException: Could not create bundle object. at org.apache.felix.framework.Felix.installBundle(Felix.java:2785) at org.apache.felix.framework.BundleContextImpl.installBundle(BundleContextImpl.java:165) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.install(BundleProvisioner.java:444) at com.sun.enterprise.glassfish.bootstrap.osgi.BundleProvisioner.installBundles(BundleProvisioner.java:203) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:141) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 at java.util.ArrayList.rangeCheck(ArrayList.java:603) at java.util.ArrayList.get(ArrayList.java:381) at org.apache.felix.framework.ExtensionManager.addExtensionBundle(ExtensionManager.java:401) at org.apache.felix.framework.Felix.installBundle(Felix.java:2751) ... 13 more ERROR: Bundle jaxb-api [2] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/endorsed/jaxb-api-osgi.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle jaxb-api [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)) org.osgi.framework.BundleException: Unresolved constraint in bundle jaxb-api [2]: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.metro.webservices-api-osgi [3] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/endorsed/webservices-api-osgi.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.metro.webservices-api-osgi [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.bind)(version>=2.2.0)) [caused by: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.metro.webservices-api-osgi [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (&(osgi.wiring.package=javax.xml.bind)(version>=2.2.0)) [caused by: Unable to resolve 2.0: missing requirement [2.0] osgi.wiring.package; (osgi.wiring.package=javax.activation)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.osgi-resource-locator [4] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/osgi-resource-locator.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-resource-locator [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-resource-locator [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0)) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.asm-all-repackaged [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) ERROR: Bundle org.glassfish.hk2.external.asm-all-repackaged [18] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/asm-all-repackaged.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.asm-all-repackaged [18]: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.external.bean-validator [20] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/bean-validator.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.bean-validator [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.script)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.bean-validator [20]: Unable to resolve 20.0: missing requirement [20.0] osgi.wiring.package; (osgi.wiring.package=javax.script) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.external.cglib [21] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/cglib.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.cglib [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.external.cglib [21]: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.config-types [36] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/config-types.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config-types [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (&(osgi.wiring.package=org.jvnet.hk2.annotations)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config-types [36]: Unable to resolve 36.0: missing requirement [36.0] osgi.wiring.package; (&(osgi.wiring.package=org.jvnet.hk2.annotations)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.core [67] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/core.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.core [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.core [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.main.core.glassfish [108] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/glassfish.jar (org.osgi.framework.BundleException: Activator start error in bundle org.glassfish.main.core.glassfish [108].) java.lang.NoClassDefFoundError: org/osgi/framework/BundleActivator at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:791) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.findClass(BundleWiringImpl.java:2128) at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1432) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843) at java.lang.ClassLoader.loadClass(ClassLoader.java:356) at org.apache.felix.framework.BundleWiringImpl.getClassByDelegation(BundleWiringImpl.java:1317) at org.apache.felix.framework.Felix.createBundleActivator(Felix.java:4170) at org.apache.felix.framework.Felix.activateBundle(Felix.java:1972) at org.apache.felix.framework.Felix.startBundle(Felix.java:1895) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) Caused by: java.lang.ClassNotFoundException: org.osgi.framework.BundleActivator not found by org.glassfish.main.core.glassfish [108] at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1460) at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:72) at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1843) at java.lang.ClassLoader.loadClass(ClassLoader.java:356) ... 14 more ERROR: Bundle org.glassfish.hk2.api [117] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-api.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.config [118] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-config.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config [118]: Unable to resolve 118.0: missing requirement [118.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.hk2.component)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 119.0: missing requirement [119.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.config [118]: Unable to resolve 118.0: missing requirement [118.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.hk2.component)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 119.0: missing requirement [119.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.locator [120] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-locator.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.locator [120]: Unable to resolve 120.0: missing requirement [120.0] osgi.wiring.package; (osgi.wiring.package=net.sf.cglib.proxy) [caused by: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.locator [120]: Unable to resolve 120.0: missing requirement [120.0] osgi.wiring.package; (osgi.wiring.package=net.sf.cglib.proxy) [caused by: Unable to resolve 21.0: missing requirement [21.0] osgi.wiring.package; (&(osgi.wiring.package=org.objectweb.asm.util)(password=GlassFish)) [caused by: Unable to resolve 18.0: missing requirement [18.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.transform)]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.runlevel [121] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/hk2-runlevel.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.apache.felix.bundlerepository [202] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/org.apache.felix.bundlerepository.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))) org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) ERROR: Bundle org.glassfish.hk2.osgi-adapter [212] Error starting file:/Users/arungup/tools/glassfish/4.0/60/glassfish3/glassfish/modules/osgi-adapter.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722) Exception in thread "main" java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:474) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97) at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55) Caused by: org.glassfish.embeddable.GlassFishException: org.glassfish.embeddable.GlassFishException: No GlassFishRuntime available at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:169) at org.glassfish.embeddable.GlassFishRuntime._bootstrap(GlassFishRuntime.java:157) at org.glassfish.embeddable.GlassFishRuntime.bootstrap(GlassFishRuntime.java:110) at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:112) ... 6 more Caused by: org.glassfish.embeddable.GlassFishException: No GlassFishRuntime available at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.getGlassFishRuntime(OSGiGlassFishRuntimeBuilder.java:207) at com.sun.enterprise.glassfish.bootstrap.osgi.OSGiGlassFishRuntimeBuilder.build(OSGiGlassFishRuntimeBuilder.java:167) ... 9 more Error stopping framework: java.lang.NullPointerException java.lang.NullPointerException at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher$1.run(GlassFishMain.java:203) Command start-domain failed. The DAS was stopped. A similar error is also reported at: http://stackoverflow.com/questions/13139794/glassfish-server-does-not-work-with-jdk-8
    via by arungupta,
  • OSGi: passing parameters to a specific bundle
    via Stack Overflow by Puce
    ,
  • User discussion for Apache Karaf OSGi Kernel
    via by Unknown author,
  • GlassFish, OS X and launchctl - Art of Coding
    via by Unknown author,
  • Unable to launch Glassfish 3.1.2.x on Mac
    via by Unknown author,
    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295) at java.lang.Thread.run(Thread.java:722)

    Users with the same issue

    davidvanlaatum
    davidvanlaatum2631 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    13 more bugmates