org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]
via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]
via java.net by Unknown author, 2 years ago
Unresolved constraint in bundle org.glassfish.hk2.api [117] : Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by
via Google Groups by Newonthesit, 4 months ago
Unresolved constraint in bundle org.apache.felix.gogo.command [3]: Unable to resolve 3.0: missing requirement [3.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.felix.service.command)(status=provisional)(version>=0.10.0)(!(version
via hivmr.com by Unknown author, 1 year ago
Unresolved constraint in bundle org.apache.aries.proxy.api [8]: Unable to resolve 8.0: missing requirement [8.0] osgi.wiring.package; ((osgi.wiring.package=org.apache.aries.util.nls)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve
via GitHub by pires
, 2 years ago
Unresolved constraint in bundle org.apache.aries.proxy.api [7]: Unable to resolve 7.0: missing requirement [7.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.aries.util.nls)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve
org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.api [117]: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
at java.lang.Thread.run(Thread.java:722)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.