org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]]

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable
via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable
via java.net by Unknown author, 2 years ago
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212] : Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)( Unable to render embedded object
via hivmr.com by Unknown author, 1 year ago
Unresolved constraint in bundle io.fabric8.fabric-configadmin [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; ((osgi.wiring.package=io.fabric8.api)(version=1.0.0)(!(version=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]
via DataStax JIRA by Zafar Khaydarov, 1 year ago
Unresolved constraint in bundle caao-osgi-bundle [4]: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=com.codahale.metrics)(version>=3.0.0)(!(version>=4.0.0))) [caused by: Unable to resolve 22.0: missing
via Stack Overflow by Paulius Matulionis
, 2 years ago
Unresolved constraint in bundle com.groupgti.esb.purge [207]: Unable to resolve 207.0: missing requirement [207.0] osgi.wiring.package ; (osgi.wiring.package=com.groupgti.esb.cxf.interceptors) [caused by: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=jav ax.servlet.http)(version>=2.6.0)(!(version>=3.0.0)))]
org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [212]: Unable to resolve 212.0: missing requirement [212.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]]
at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
at java.lang.Thread.run(Thread.java:722)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.