org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]


Solutions on the web

Solution icon of java
via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to

Solution icon of java
via Java.net JIRA by arungupta, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to

Solution icon of web
( Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)() not found. (version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]

Solution icon of stackoverflow
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [203]: Unable to resolve 203.0: missing requirement [203.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Solution icon of web
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Solution icon of coderanch
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Solution icon of web
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Solution icon of youtrack
via YouTrack by Unknown author, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Solution icon of web
via developpez.net by Unknown author, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Solution icon of web
via art-of-coding.eu by Unknown author, 1 year ago
Unresolved constraint in bundle org.glassfish.hk2.osgi-adapter [202]: Unable to resolve 202.0: missing requirement [202.0] osgi.wiring.package; (&(osgi.wiring.package=com.sun.enterprise.module)(version>=1.1.0)) [caused by: Unable to resolve 121.0

Stack trace

org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.hk2.runlevel [121]: Unable to resolve 121.0: missing requirement [121.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.api)(version>=2.1.0)(!(version>=3.0.0))) [caused by: Unable to resolve 117.0: missing requirement [117.0] osgi.wiring.package; (&(osgi.wiring.package=org.glassfish.hk2.osgiresourcelocator)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 4.0: missing requirement [4.0] osgi.wiring.package; (&(osgi.wiring.package=org.osgi.framework)(version>=1.5.0))]]
	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826)
	at org.apache.felix.framework.Felix.startBundle(Felix.java:1868)
	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191)
	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:295)
	at java.lang.Thread.run(Thread.java:722)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

Users with the same issue

2631 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
14 more bugmates