javax.servlet.ServletException

ERROR: The java component class: business.SMS from the component named: jcComp2 does not have a public, no-argument constructor.

Samebug tips0

There are no available Samebug tips.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web12

Stack trace

  • javax.servlet.ServletException: ERROR: The java component class: business.SMS from the component named: jcComp2 does not have a public, no-argument constructor. at weblogic.webservice.server.servlet.WebServiceServlet.initLocal(WebServiceServlet.java:132) at weblogic.webservice.server.servlet.WebServiceServlet.init(WebServiceServlet.java:86) at javax.servlet.GenericServlet.init(GenericServlet.java:258) at weblogic.servlet.internal.ServletStubImpl$ServletInitAction.run(ServletStubImpl.java:993) at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:317) at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:118) at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:869) at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:848) at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:787) at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:3252) at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:3197) at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:3174) at weblogic.servlet.internal.HttpServer.preloadResources(HttpServer.java:688) at weblogic.servlet.internal.WebService.preloadResources(WebService.java:483) at weblogic.servlet.internal.ServletInitService.resume(ServletInitService.java:30) at weblogic.t3.srvr.SubsystemManager.resume(SubsystemManager.java:131) at weblogic.t3.srvr.T3Srvr.resume(T3Srvr.java:964) at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:359) at weblogic.Server.main(Server.java:32)

Write tip

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

No Bugmate found.