org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via Spring JIRA by Artem, 1 year ago
Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [49]: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by
via Spring JIRA by Artem, 1 year ago
Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [49]: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by
via Spring JIRA by Krishna Srinivasan, 1 year ago
Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]
via Stack Overflow by Lucas
, 1 year ago
Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]
via Spring JIRA by Krishna Srinivasan, 1 year ago
Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]
via Super User by Marek
, 1 year ago
Unresolved constraint in bundle org.springframework.roo.addon.configurable [8]: Unable to resolve 8.0: missing requirement [8.0] package; (&(package=org.springframework.roo.classpath)(version>=1.1.0)(!(version>=2.0.0))) [caused by: Unable to resolve
org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
at java.lang.Thread.run(Thread.java:744)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 2 years ago
2 times, 9 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
2 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.