org.osgi.framework.BundleException

Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web241

  • via Unknown by Artem,
  • via Unknown by Artem,
  • via Unknown by Krishna Srinivasan,
  • Stack trace

    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    andyglickandyglick
    2 times, last one
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    Unknown visitor
    Unknown visitorOnce,
    2 more bugmates