org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)

Spring JIRA | Artem | 3 years ago
  1. 0

    When I try to run the command "Roo" after installing the Spring Roo, I get the following exception thrown in console: ERROR: Bundle org.springframework.roo.support.osgi [70] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.support.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.uaa [71] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.uaa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.url.stream.jdk [73] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.url.stream.jdk-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [74] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [76] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.wrapping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.uaa.client [81] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.uaa.client-1.0.2.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744)

    Spring JIRA | 3 years ago | Krishna Srinivasan
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)
  2. 0

    Steps to repro: 1. Install latest Mac OS X 10.9.2 + Oracle Java 8 + Maven 3.2.1 2. Download and unzip Roo 1.2.5.RELEASE to some folder 3. Create a new directory for a new project and cd into it; 4. try to call roo.sh from unzipped location. Expected: Roo command line will appear Actual: {noformat} ERROR: Bundle com.github.antlrjavaparser.antlr-java-parser [3] Error starting file:/Users/artem/apps/roo125/bundle/antlr-java-parser-1.0.14.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.github.antlrjavaparser.antlr-java-parser [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.github.antlrjavaparser.antlr-java-parser [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.backup [18] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.backup-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [18]: Unable to resolve 18.0: missing requirement [18.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [18]: Unable to resolve 18.0: missing requirement [18.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.configurable [19] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.configurable-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [19]: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [19]: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.creator [20] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.creator-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.dbre [21] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.dbre-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [21]: Unable to resolve 21.0: missing requirement [21.0] package; (package=javax.naming)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [21]: Unable to resolve 21.0: missing requirement [21.0] package; (package=javax.naming) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.dod [22] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.dod-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [22]: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [22]: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.email [23] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.email-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.email [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.email [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.equals [24] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.equals-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.equals [24]: Unable to resolve 24.0: missing requirement [24.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.equals [24]: Unable to resolve 24.0: missing requirement [24.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.finder [25] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.finder-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.gwt [26] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.gwt-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.gwt [26]: Unable to resolve 26.0: missing requirement [26.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.gwt [26]: Unable to resolve 26.0: missing requirement [26.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.javabean [27] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.javabean-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.javabean [27]: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.javabean [27]: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jdbc [28] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jdbc-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jdbc [28]: Unable to resolve 28.0: missing requirement [28.0] package; (&(package=org.springframework.roo.support.api)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jdbc [28]: Unable to resolve 28.0: missing requirement [28.0] package; (&(package=org.springframework.roo.support.api)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jms [29] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jms-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jms [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jms [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jpa [30] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jpa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jpa [30]: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jpa [30]: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jsf [31] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jsf-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jsf [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jsf [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.json [32] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.json-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.json [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.json [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.layers.repository.jpa [33] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.layers.repository.jpa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.jpa [33]: Unable to resolve 33.0: missing requirement [33.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.jpa [33]: Unable to resolve 33.0: missing requirement [33.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.layers.repository.mongo [34] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.layers.repository.mongo-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.layers.service [35] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.layers.service-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.service [35]: Unable to resolve 35.0: missing requirement [35.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.service [35]: Unable to resolve 35.0: missing requirement [35.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.logging [36] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.logging-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.logging [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.logging [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.oscommands [37] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.oscommands-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.oscommands [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.oscommands [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.plural [38] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.plural-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.plural [38]: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.plural [38]: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.property.editor [39] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.property.editor-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [39]: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [39]: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.propfiles [40] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.propfiles-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.propfiles [40]: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.propfiles [40]: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.roobot.client [41] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.roobot.client-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.roobot.client [41]: Unable to resolve 41.0: missing requirement [41.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.roobot.client [41]: Unable to resolve 41.0: missing requirement [41.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.security [42] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.security-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.security [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp.tiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.security [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp.tiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.serializable [43] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.serializable-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.serializable [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.serializable [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.solr [44] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.solr-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.solr [44]: Unable to resolve 44.0: missing requirement [44.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.solr [44]: Unable to resolve 44.0: missing requirement [44.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.tailor [45] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.tailor-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tailor [45]: Unable to resolve 45.0: missing requirement [45.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tailor [45]: Unable to resolve 45.0: missing requirement [45.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.test [46] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.test-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.test [46]: Unable to resolve 46.0: missing requirement [46.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.test [46]: Unable to resolve 46.0: missing requirement [46.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.tostring [47] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.tostring-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tostring [47]: Unable to resolve 47.0: missing requirement [47.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tostring [47]: Unable to resolve 47.0: missing requirement [47.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.flow [48] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.flow-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.flow [48]: Unable to resolve 48.0: missing requirement [48.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.flow [48]: Unable to resolve 48.0: missing requirement [48.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.mvc.controller [49] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.mvc.controller-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [49]: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [49]: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.mvc.embedded [50] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.mvc.embedded-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.embedded [50]: Unable to resolve 50.0: missing requirement [50.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.embedded [50]: Unable to resolve 50.0: missing requirement [50.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.mvc.jsp [51] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.mvc.jsp-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.jsp [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.jsp [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.selenium [52] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.selenium-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.selenium [52]: Unable to resolve 52.0: missing requirement [52.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller.details)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.selenium [52]: Unable to resolve 52.0: missing requirement [52.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller.details)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.classpath [53] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.classpath-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.classpath.antlrjavaparser [54] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.classpath.antlrjavaparser-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.antlrjavaparser [54]: Unable to resolve 54.0: missing requirement [54.0] package; (&(package=com.github.antlrjavaparser)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.antlrjavaparser [54]: Unable to resolve 54.0: missing requirement [54.0] package; (&(package=com.github.antlrjavaparser)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.felix [55] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.felix-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.felix [55]: Unable to resolve 55.0: missing requirement [55.0] package; (&(package=org.bouncycastle.jce.provider)(version>=1.45.0)(!(version>=2.0.0))) [caused by: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.felix [55]: Unable to resolve 55.0: missing requirement [55.0] package; (&(package=org.bouncycastle.jce.provider)(version>=1.45.0)(!(version>=2.0.0))) [caused by: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.monitor [56] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.monitor-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor [56]: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor [56]: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.monitor.polling [57] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.monitor.polling-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling [57]: Unable to resolve 57.0: missing requirement [57.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling [57]: Unable to resolve 57.0: missing requirement [57.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.monitor.polling.roo [58] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.monitor.polling.roo-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling.roo [58]: Unable to resolve 58.0: missing requirement [58.0] package; (&(package=org.springframework.roo.file.monitor.event)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling.roo [58]: Unable to resolve 58.0: missing requirement [58.0] package; (&(package=org.springframework.roo.file.monitor.event)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.undo [59] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.undo-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.undo [59]: Unable to resolve 59.0: missing requirement [59.0] package; (&(package=org.springframework.roo.support.logging)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.undo [59]: Unable to resolve 59.0: missing requirement [59.0] package; (&(package=org.springframework.roo.support.logging)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.model [61] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.model-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [61]: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [61]: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.process.manager [62] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.process.manager-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.process.manager [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.process.manager [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.project [63] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.project-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [63]: Unable to resolve 63.0: missing requirement [63.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [63]: Unable to resolve 63.0: missing requirement [63.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell [64] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell [64]: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell [64]: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell.jline [65] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell.jline-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline [65]: Unable to resolve 65.0: missing requirement [65.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline [65]: Unable to resolve 65.0: missing requirement [65.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell.jline.osgi [66] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell.jline.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell.osgi [67] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.osgi [67]: Unable to resolve 67.0: missing requirement [67.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.osgi [67]: Unable to resolve 67.0: missing requirement [67.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.startlevel [68] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.startlevel-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.startlevel [68]: Unable to resolve 68.0: missing requirement [68.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.startlevel [68]: Unable to resolve 68.0: missing requirement [68.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.support [69] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.support-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support [69]: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support [69]: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.support.osgi [70] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.support.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.uaa [71] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.uaa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.url.stream.jdk [73] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.url.stream.jdk-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [74] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [76] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.wrapping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.uaa.client [81] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.uaa.client-1.0.2.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) {noformat}

    Spring JIRA | 3 years ago | Artem
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)
  3. 0

    When I try to run the command "Roo" after installing the Spring Roo, I get the following exception thrown in console: ERROR: Bundle org.springframework.roo.support.osgi [70] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.support.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.uaa [71] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.uaa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.url.stream.jdk [73] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.url.stream.jdk-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [74] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [76] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.roo.wrapping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.uaa.client [81] Error starting file:/home/krishna/Downloads/javabeat/spring-roo/bundle/org.springframework.uaa.client-1.0.2.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744)

    Spring JIRA | 3 years ago | Krishna Srinivasan
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Steps to repro: 1. Install latest Mac OS X 10.9.2 + Oracle Java 8 + Maven 3.2.1 2. Download and unzip Roo 1.2.5.RELEASE to some folder 3. Create a new directory for a new project and cd into it; 4. try to call roo.sh from unzipped location. Expected: Roo command line will appear Actual: {noformat} ERROR: Bundle com.github.antlrjavaparser.antlr-java-parser [3] Error starting file:/Users/artem/apps/roo125/bundle/antlr-java-parser-1.0.14.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle com.github.antlrjavaparser.antlr-java-parser [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]) org.osgi.framework.BundleException: Unresolved constraint in bundle com.github.antlrjavaparser.antlr-java-parser [3]: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.backup [18] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.backup-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [18]: Unable to resolve 18.0: missing requirement [18.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.backup [18]: Unable to resolve 18.0: missing requirement [18.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.configurable [19] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.configurable-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [19]: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.configurable [19]: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.creator [20] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.creator-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.creator [20]: Unable to resolve 20.0: missing requirement [20.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.dbre [21] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.dbre-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [21]: Unable to resolve 21.0: missing requirement [21.0] package; (package=javax.naming)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dbre [21]: Unable to resolve 21.0: missing requirement [21.0] package; (package=javax.naming) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.dod [22] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.dod-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [22]: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.dod [22]: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.email [23] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.email-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.email [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.email [23]: Unable to resolve 23.0: missing requirement [23.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.equals [24] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.equals-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.equals [24]: Unable to resolve 24.0: missing requirement [24.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.equals [24]: Unable to resolve 24.0: missing requirement [24.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.finder [25] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.finder-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.finder [25]: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.gwt [26] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.gwt-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.gwt [26]: Unable to resolve 26.0: missing requirement [26.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.gwt [26]: Unable to resolve 26.0: missing requirement [26.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.javabean [27] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.javabean-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.javabean [27]: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.javabean [27]: Unable to resolve 27.0: missing requirement [27.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jdbc [28] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jdbc-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jdbc [28]: Unable to resolve 28.0: missing requirement [28.0] package; (&(package=org.springframework.roo.support.api)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jdbc [28]: Unable to resolve 28.0: missing requirement [28.0] package; (&(package=org.springframework.roo.support.api)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jms [29] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jms-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jms [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jms [29]: Unable to resolve 29.0: missing requirement [29.0] package; (&(package=org.springframework.roo.addon.propfiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jpa [30] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jpa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jpa [30]: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jpa [30]: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.jsf [31] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.jsf-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jsf [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.jsf [31]: Unable to resolve 31.0: missing requirement [31.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.json [32] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.json-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.json [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.json [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.springframework.roo.addon.plural)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.layers.repository.jpa [33] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.layers.repository.jpa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.jpa [33]: Unable to resolve 33.0: missing requirement [33.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.jpa [33]: Unable to resolve 33.0: missing requirement [33.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.layers.repository.mongo [34] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.layers.repository.mongo-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.repository.mongo [34]: Unable to resolve 34.0: missing requirement [34.0] package; (&(package=org.springframework.roo.addon.dod)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 22.0: missing requirement [22.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.layers.service [35] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.layers.service-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.service [35]: Unable to resolve 35.0: missing requirement [35.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.layers.service [35]: Unable to resolve 35.0: missing requirement [35.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.logging [36] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.logging-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.logging [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.logging [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.springframework.roo.model)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.oscommands [37] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.oscommands-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.oscommands [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.oscommands [37]: Unable to resolve 37.0: missing requirement [37.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.plural [38] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.plural-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.plural [38]: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.plural [38]: Unable to resolve 38.0: missing requirement [38.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.property.editor [39] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.property.editor-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [39]: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.property.editor [39]: Unable to resolve 39.0: missing requirement [39.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.propfiles [40] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.propfiles-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.propfiles [40]: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.propfiles [40]: Unable to resolve 40.0: missing requirement [40.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.roobot.client [41] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.roobot.client-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.roobot.client [41]: Unable to resolve 41.0: missing requirement [41.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.roobot.client [41]: Unable to resolve 41.0: missing requirement [41.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.security [42] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.security-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.security [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp.tiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.security [42]: Unable to resolve 42.0: missing requirement [42.0] package; (&(package=org.springframework.roo.addon.web.mvc.jsp.tiles)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.serializable [43] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.serializable-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.serializable [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.serializable [43]: Unable to resolve 43.0: missing requirement [43.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.solr [44] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.solr-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.solr [44]: Unable to resolve 44.0: missing requirement [44.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.solr [44]: Unable to resolve 44.0: missing requirement [44.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.tailor [45] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.tailor-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tailor [45]: Unable to resolve 45.0: missing requirement [45.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tailor [45]: Unable to resolve 45.0: missing requirement [45.0] package; (&(package=org.springframework.roo.process.manager)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.test [46] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.test-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.test [46]: Unable to resolve 46.0: missing requirement [46.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.test [46]: Unable to resolve 46.0: missing requirement [46.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.tostring [47] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.tostring-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tostring [47]: Unable to resolve 47.0: missing requirement [47.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.tostring [47]: Unable to resolve 47.0: missing requirement [47.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.flow [48] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.flow-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.flow [48]: Unable to resolve 48.0: missing requirement [48.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.flow [48]: Unable to resolve 48.0: missing requirement [48.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.mvc.controller [49] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.mvc.controller-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [49]: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.controller [49]: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.mvc.embedded [50] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.mvc.embedded-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.embedded [50]: Unable to resolve 50.0: missing requirement [50.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.embedded [50]: Unable to resolve 50.0: missing requirement [50.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.mvc.jsp [51] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.mvc.jsp-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.jsp [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.mvc.jsp [51]: Unable to resolve 51.0: missing requirement [51.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.addon.web.selenium [52] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.addon.web.selenium-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.selenium [52]: Unable to resolve 52.0: missing requirement [52.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller.details)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.addon.web.selenium [52]: Unable to resolve 52.0: missing requirement [52.0] package; (&(package=org.springframework.roo.addon.web.mvc.controller.details)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 49.0: missing requirement [49.0] package; (&(package=org.springframework.roo.addon.finder)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 25.0: missing requirement [25.0] package; (&(package=org.springframework.roo.addon.jpa.activerecord)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 30.0: missing requirement [30.0] package; (&(package=org.springframework.roo.addon.configurable)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 19.0: missing requirement [19.0] package; (&(package=org.springframework.roo.classpath)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]]]]]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.classpath [53] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.classpath-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath [53]: Unable to resolve 53.0: missing requirement [53.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.classpath.antlrjavaparser [54] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.classpath.antlrjavaparser-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.antlrjavaparser [54]: Unable to resolve 54.0: missing requirement [54.0] package; (&(package=com.github.antlrjavaparser)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.classpath.antlrjavaparser [54]: Unable to resolve 54.0: missing requirement [54.0] package; (&(package=com.github.antlrjavaparser)(version>=1.0.0)(!(version>=2.0.0))) [caused by: Unable to resolve 3.0: missing requirement [3.0] package; (package=org.antlr.v4.runtime) [caused by: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.felix [55] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.felix-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.felix [55]: Unable to resolve 55.0: missing requirement [55.0] package; (&(package=org.bouncycastle.jce.provider)(version>=1.45.0)(!(version>=2.0.0))) [caused by: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.felix [55]: Unable to resolve 55.0: missing requirement [55.0] package; (&(package=org.bouncycastle.jce.provider)(version>=1.45.0)(!(version>=2.0.0))) [caused by: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.monitor [56] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.monitor-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor [56]: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor [56]: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.monitor.polling [57] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.monitor.polling-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling [57]: Unable to resolve 57.0: missing requirement [57.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling [57]: Unable to resolve 57.0: missing requirement [57.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.monitor.polling.roo [58] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.monitor.polling.roo-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling.roo [58]: Unable to resolve 58.0: missing requirement [58.0] package; (&(package=org.springframework.roo.file.monitor.event)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.monitor.polling.roo [58]: Unable to resolve 58.0: missing requirement [58.0] package; (&(package=org.springframework.roo.file.monitor.event)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.file.undo [59] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.file.undo-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.undo [59]: Unable to resolve 59.0: missing requirement [59.0] package; (&(package=org.springframework.roo.support.logging)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.file.undo [59]: Unable to resolve 59.0: missing requirement [59.0] package; (&(package=org.springframework.roo.support.logging)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.model [61] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.model-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [61]: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.model [61]: Unable to resolve 61.0: missing requirement [61.0] package; (package=javax.annotation) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.process.manager [62] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.process.manager-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.process.manager [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.process.manager [62]: Unable to resolve 62.0: missing requirement [62.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.project [63] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.project-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [63]: Unable to resolve 63.0: missing requirement [63.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.project [63]: Unable to resolve 63.0: missing requirement [63.0] package; (&(package=org.springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 56.0: missing requirement [56.0] package; (&(package=org.springframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell [64] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell [64]: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell [64]: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell.jline [65] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell.jline-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline [65]: Unable to resolve 65.0: missing requirement [65.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline [65]: Unable to resolve 65.0: missing requirement [65.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell.jline.osgi [66] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell.jline.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.shell.osgi [67] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.shell.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.osgi [67]: Unable to resolve 67.0: missing requirement [67.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.osgi [67]: Unable to resolve 67.0: missing requirement [67.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.startlevel [68] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.startlevel-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.startlevel [68]: Unable to resolve 68.0: missing requirement [68.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.startlevel [68]: Unable to resolve 68.0: missing requirement [68.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.support [69] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.support-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support [69]: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support [69]: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.support.osgi [70] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.support.osgi-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.support.osgi [70]: Unable to resolve 70.0: missing requirement [70.0] package; (&(package=org.springframework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 69.0: missing requirement [69.0] package; (package=javax.xml.namespace)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.uaa [71] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.uaa-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.uaa [71]: Unable to resolve 71.0: missing requirement [71.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.url.stream.jdk [73] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.url.stream.jdk-1.2.5.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.url.stream.jdk [73]: Unable to resolve 73.0: missing requirement [73.0] package; (&(package=org.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 64.0: missing requirement [64.0] package; (package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [74] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [74]: Unable to resolve 74.0: missing requirement [74.0] package; (package=javax.imageio) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [76] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.roo.wrapping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) ERROR: Bundle org.springframework.uaa.client [81] Error starting file:/Users/artem/apps/roo125/bundle/org.springframework.uaa.client-1.0.2.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.uaa.client [81]: Unable to resolve 81.0: missing requirement [81.0] package; (package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564) at org.apache.felix.framework.Felix.startBundle(Felix.java:1797) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192) at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266) at java.lang.Thread.run(Thread.java:744) {noformat}

    Spring JIRA | 3 years ago | Artem
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)
  6. 0

    Cannot run Spring Roo shell - "Unable to resolve .. missing requirement .. package=javax.xml..."

    Stack Overflow | 2 years ago | Lucas
    org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)

    3 unregistered visitors
    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. org.osgi.framework.BundleException

      Unresolved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [76]: Unable to resolve 76.0: missing requirement [76.0] package; (package=javax.crypto)

      at org.apache.felix.framework.Felix.resolveBundle()
    2. Apache Felix Framework
      StartLevelImpl.run
      1. org.apache.felix.framework.Felix.resolveBundle(Felix.java:3564)
      2. org.apache.felix.framework.Felix.startBundle(Felix.java:1797)
      3. org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1192)
      4. org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:266)
      4 frames
    3. Java RT
      Thread.run
      1. java.lang.Thread.run(Thread.java:744)
      1 frame