org.osgi.framework.BundleException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.process.manager [61] Error starting file:/ C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.process. manager-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constr aint in bundle org.springframework.roo.process.manager [61]: Unable to resolve 6 1.0: missing requirement [61.0] osgi.wiring.package; (&(osgi.wiring.package=org. springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by : Unable to resolve 55.0: missing requirement [55.0] osgi.wiring.package; (&(osg i.wiring.package=org.springframework.roo.support.util)(version>=1.2.0)(!(version >=2.0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0] osgi.w iring.package; (osgi.wiring.package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.process.manager [61]: Unable to resolve 61.0: missing requirement [6 1.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.file.mo nitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0: m issing requirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=org.spring framework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unab le to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring .package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.project [62] Error starting file:/C:/sprin gsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.project-1.2.4.RE LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle o rg.springframework.roo.project [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.file .monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0 : missing requirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=org.spr ingframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: U nable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wir ing.package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.project [62]: Unable to resolve 62.0: missing requirement [62.0] osg i.wiring.package; (&(osgi.wiring.package=org.springframework.roo.file.monitor)(v ersion>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0: missing r equirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframewor k.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to re solve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package =javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell [63] Error starting file:/C:/springs ource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell-1.2.4.RELEAS E.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.s pringframework.roo.shell [63]: Unable to resolve 63.0: missing requirement [63.0 ] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell [63]: Unable to resolve 63.0: missing requirement [63.0] osgi. wiring.package; (osgi.wiring.package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell.jline [64] Error starting file:/C:/s pringsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell.jline- 1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframew ork.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=java x.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.jline [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(vers ion>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requ irement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell.jline.osgi [65] Error starting file: /C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell.j line.osgi-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved cons traint in bundle org.springframework.roo.shell.jline.osgi [65]: Unable to resolv e 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=o rg.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Un able to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiri ng.package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.jline.osgi [65]: Unable to resolve 65.0: missing requirement [ 65.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell) (version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) ] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell.osgi [66] Error starting file:/C:/sp ringsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell.osgi-1. 2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bu ndle org.springframework.roo.shell.osgi [66]: Unable to resolve 66.0: missing re quirement [66.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework .roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63 .0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.x ml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(versi on>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requi rement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.startlevel [67] Error starting file:/C:/sp ringsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.startlevel-1. 2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bu ndle org.springframework.roo.startlevel [67]: Unable to resolve 67.0: missing re quirement [67.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.startlevel [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.support [68] Error starting file:/C:/sprin gsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.support-1.2.4.RE LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle o rg.springframework.roo.support [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.support [68]: Unable to resolve 68.0: missing requirement [68.0] osg i.wiring.package; (osgi.wiring.package=javax.xml.namespace) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.support.osgi [69] Error starting file:/C:/ springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.support.osg i-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint i n bundle org.springframework.roo.support.osgi [69]: Unable to resolve 69.0: miss ing requirement [69.0] osgi.wiring.package; (&(osgi.wiring.package=org.springfra mework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable t o resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.pac kage=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.support.osgi [69]: Unable to resolve 69.0: missing requirement [69.0 ] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.support.an t)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 68.0: missi ng requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namesp ace)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.uaa [70] Error starting file:/C:/springsou rce/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.uaa-1.2.4.RELEASE.ja r (org.osgi.framework.BundleException: Unresolved constraint in bundle org.sprin gframework.roo.uaa [70]: Unable to resolve 70.0: missing requirement [70.0] osgi .wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(version>= 1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requireme nt [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.uaa [70]: Unable to resolve 70.0: missing requirement [70.0] osgi.wi ring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(version>=1.2 .0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.url.stream.jdk [72] Error starting file:/C :/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.url.strea m.jdk-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constrai nt in bundle org.springframework.roo.url.stream.jdk [72]: Unable to resolve 72.0 : missing requirement [72.0] osgi.wiring.package; (&(osgi.wiring.package=org.spr ingframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable t o resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.pac kage=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.url.stream.jdk [72]: Unable to resolve 72.0: missing requirement [72 .0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(v ersion>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing r equirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [73] Error startin g file:/C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo. wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unreso lved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [73]: Unable to resolve 73.0: missing requirement [73.0] osgi.wiring.package; (osgi.wi ring.package=javax.imageio)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.wrapping.antlr4-runtime [73]: Unable to resolve 73.0: missing requir ement [73.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [75] Error starting file:/C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.wr apping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresol ved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [75]: Una ble to resolve 75.0: missing requirement [75.0] osgi.wiring.package; (osgi.wirin g.package=javax.crypto)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.wrapping.bcprov-jdk15 [75]: Unable to resolve 75.0: missing requirem ent [75.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.uaa.client [80] Error starting file:/C:/spring source/spring-roo-1.2.4.RELEASE/bundle/org.springframework.uaa.client-1.0.2.RELE ASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org .springframework.uaa.client [80]: Unable to resolve 80.0: missing requirement [8 0.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.uaa.client [80]: Unable to resolve 80.0: missing requirement [80.0] osgi .wiring.package; (osgi.wiring.package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) Terminate batch job (Y/N)? y C:\Users\Rad\Desktop\Javabqt\Bqtfpprint>hint 'hint' is not recognized as an internal or external command, operable program or batch file. C:\Users\Rad\Desktop\Javabqt\Bqtfpprint> C:\Users\Rad\Desktop\Javabqt\Bqtfpprint>mvn --version Apache Maven 3.1.1 (0728685237757ffbf44136acec0402957f723d9a; 2013-09-17 20:52:2 2+0530) Maven home: C:\springsource\apache-maven-3.1.1\bin\.. Java version: 1.6.0_17, vendor: Sun Microsystems Inc. Java home: C:\Program Files (x86)\Java\jdk1.6.0_17\jre Default locale: en_US, platform encoding: Cp1252 OS name: "windows nt (unknown)", version: "6.2", arch: "x86", family: "windows" C:\Users\Rad\Desktop\Javabqt\Bqtfpprint>
    via by Shivarsenthil,
  • 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.process.manager [61] Error starting file:/ C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.process. manager-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constr aint in bundle org.springframework.roo.process.manager [61]: Unable to resolve 6 1.0: missing requirement [61.0] osgi.wiring.package; (&(osgi.wiring.package=org. springframework.roo.file.monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by : Unable to resolve 55.0: missing requirement [55.0] osgi.wiring.package; (&(osg i.wiring.package=org.springframework.roo.support.util)(version>=1.2.0)(!(version >=2.0.0))) [caused by: Unable to resolve 68.0: missing requirement [68.0] osgi.w iring.package; (osgi.wiring.package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.process.manager [61]: Unable to resolve 61.0: missing requirement [6 1.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.file.mo nitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0: m issing requirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=org.spring framework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unab le to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring .package=javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.project [62] Error starting file:/C:/sprin gsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.project-1.2.4.RE LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle o rg.springframework.roo.project [62]: Unable to resolve 62.0: missing requirement [62.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.file .monitor)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0 : missing requirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=org.spr ingframework.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: U nable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wir ing.package=javax.xml.namespace)]]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.project [62]: Unable to resolve 62.0: missing requirement [62.0] osg i.wiring.package; (&(osgi.wiring.package=org.springframework.roo.file.monitor)(v ersion>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 55.0: missing r equirement [55.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframewor k.roo.support.util)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to re solve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package =javax.xml.namespace)]] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell [63] Error starting file:/C:/springs ource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell-1.2.4.RELEAS E.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.s pringframework.roo.shell [63]: Unable to resolve 63.0: missing requirement [63.0 ] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell [63]: Unable to resolve 63.0: missing requirement [63.0] osgi. wiring.package; (osgi.wiring.package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell.jline [64] Error starting file:/C:/s pringsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell.jline- 1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org.springframework.roo.shell.jline [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframew ork.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=java x.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.jline [64]: Unable to resolve 64.0: missing requirement [64.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(vers ion>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requ irement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell.jline.osgi [65] Error starting file: /C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell.j line.osgi-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved cons traint in bundle org.springframework.roo.shell.jline.osgi [65]: Unable to resolv e 65.0: missing requirement [65.0] osgi.wiring.package; (&(osgi.wiring.package=o rg.springframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Un able to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiri ng.package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.jline.osgi [65]: Unable to resolve 65.0: missing requirement [ 65.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell) (version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) ] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.shell.osgi [66] Error starting file:/C:/sp ringsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.shell.osgi-1. 2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bu ndle org.springframework.roo.shell.osgi [66]: Unable to resolve 66.0: missing re quirement [66.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework .roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63 .0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.x ml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(versi on>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requi rement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.startlevel [67] Error starting file:/C:/sp ringsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.startlevel-1. 2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bu ndle org.springframework.roo.startlevel [67]: Unable to resolve 67.0: missing re quirement [67.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.startlevel [67]: Unable to resolve 67.0: missing requirement [67.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.support [68] Error starting file:/C:/sprin gsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.support-1.2.4.RE LEASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle o rg.springframework.roo.support [68]: Unable to resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namespace)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.support [68]: Unable to resolve 68.0: missing requirement [68.0] osg i.wiring.package; (osgi.wiring.package=javax.xml.namespace) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.support.osgi [69] Error starting file:/C:/ springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.support.osg i-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constraint i n bundle org.springframework.roo.support.osgi [69]: Unable to resolve 69.0: miss ing requirement [69.0] osgi.wiring.package; (&(osgi.wiring.package=org.springfra mework.roo.support.ant)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable t o resolve 68.0: missing requirement [68.0] osgi.wiring.package; (osgi.wiring.pac kage=javax.xml.namespace)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.support.osgi [69]: Unable to resolve 69.0: missing requirement [69.0 ] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.support.an t)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 68.0: missi ng requirement [68.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.namesp ace)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.uaa [70] Error starting file:/C:/springsou rce/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.uaa-1.2.4.RELEASE.ja r (org.osgi.framework.BundleException: Unresolved constraint in bundle org.sprin gframework.roo.uaa [70]: Unable to resolve 70.0: missing requirement [70.0] osgi .wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(version>= 1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requireme nt [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.uaa [70]: Unable to resolve 70.0: missing requirement [70.0] osgi.wi ring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(version>=1.2 .0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.url.stream.jdk [72] Error starting file:/C :/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.url.strea m.jdk-1.2.4.RELEASE.jar (org.osgi.framework.BundleException: Unresolved constrai nt in bundle org.springframework.roo.url.stream.jdk [72]: Unable to resolve 72.0 : missing requirement [72.0] osgi.wiring.package; (&(osgi.wiring.package=org.spr ingframework.roo.shell)(version>=1.2.0)(!(version>=2.0.0))) [caused by: Unable t o resolve 63.0: missing requirement [63.0] osgi.wiring.package; (osgi.wiring.pac kage=javax.xml.parsers)]) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.url.stream.jdk [72]: Unable to resolve 72.0: missing requirement [72 .0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(v ersion>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing r equirement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.wrapping.antlr4-runtime [73] Error startin g file:/C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo. wrapping.antlr4-runtime-4.0.0002.jar (org.osgi.framework.BundleException: Unreso lved constraint in bundle org.springframework.roo.wrapping.antlr4-runtime [73]: Unable to resolve 73.0: missing requirement [73.0] osgi.wiring.package; (osgi.wi ring.package=javax.imageio)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.wrapping.antlr4-runtime [73]: Unable to resolve 73.0: missing requir ement [73.0] osgi.wiring.package; (osgi.wiring.package=javax.imageio) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.roo.wrapping.bcprov-jdk15 [75] Error starting file:/C:/springsource/spring-roo-1.2.4.RELEASE/bundle/org.springframework.roo.wr apping.bcprov-jdk15-1.45.0.0010.jar (org.osgi.framework.BundleException: Unresol ved constraint in bundle org.springframework.roo.wrapping.bcprov-jdk15 [75]: Una ble to resolve 75.0: missing requirement [75.0] osgi.wiring.package; (osgi.wirin g.package=javax.crypto)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.wrapping.bcprov-jdk15 [75]: Unable to resolve 75.0: missing requirem ent [75.0] osgi.wiring.package; (osgi.wiring.package=javax.crypto) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) ERROR: Bundle org.springframework.uaa.client [80] Error starting file:/C:/spring source/spring-roo-1.2.4.RELEASE/bundle/org.springframework.uaa.client-1.0.2.RELE ASE.jar (org.osgi.framework.BundleException: Unresolved constraint in bundle org .springframework.uaa.client [80]: Unable to resolve 80.0: missing requirement [8 0.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)) org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.uaa.client [80]: Unable to resolve 80.0: missing requirement [80.0] osgi .wiring.package; (osgi.wiring.package=javax.xml.parsers) at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:382 6) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStart LevelImpl.java:295) at java.lang.Thread.run(Unknown Source) Terminate batch job (Y/N)? y C:\Users\Rad\Desktop\Javabqt\Bqtfpprint>hint 'hint' is not recognized as an internal or external command, operable program or batch file. C:\Users\Rad\Desktop\Javabqt\Bqtfpprint> C:\Users\Rad\Desktop\Javabqt\Bqtfpprint>mvn --version Apache Maven 3.1.1 (0728685237757ffbf44136acec0402957f723d9a; 2013-09-17 20:52:2 2+0530) Maven home: C:\springsource\apache-maven-3.1.1\bin\.. Java version: 1.6.0_17, vendor: Sun Microsystems Inc. Java home: C:\Program Files (x86)\Java\jdk1.6.0_17\jre Default locale: en_US, platform encoding: Cp1252 OS name: "windows nt (unknown)", version: "6.2", arch: "x86", family: "windows" C:\Users\Rad\Desktop\Javabqt\Bqtfpprint>
    via by Shivarsenthil,
  • Unable to start Felix with gogo under tomcat
    via by Unknown author,
  • GLASSFISH 3 DOMAIN SERVICE ERROR
    via Stack Overflow by DES
    ,
  • [Tika-dev] trunk test failure - Grokbase
    via by Unknown author,
    • org.osgi.framework.BundleException: Unresolved constraint in bundle org.springfr amework.roo.shell.osgi [66]: Unable to resolve 66.0: missing requirement [66.0] osgi.wiring.package; (&(osgi.wiring.package=org.springframework.roo.shell)(versi on>=1.2.0)(!(version>=2.0.0))) [caused by: Unable to resolve 63.0: missing requi rement [63.0] osgi.wiring.package; (osgi.wiring.package=javax.xml.parsers)] at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3826) at org.apache.felix.framework.Felix.startBundle(Felix.java:1868) at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1191) at java.lang.Thread.run(Unknown Source)

    Users with the same issue

    davidvanlaatum
    14 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    13 more bugmates