java.lang.NoClassDefFoundError

org/jbpm/graph/def/ProcessDefinition

Samebug tips8

You might've forgot to add a dependency or it's written wrong. Also, you might be using incompatible versions of Java and Hibernate. More on this here: https://goo.gl/SjSlRA

This error means there's a class missing in your classpath during runtime. You need to create a jar with all your dependencies and have it in your classpath. Check Maven Assembly Plugin and how to add your dependencies to a jar: https://goo.gl/U2zr8k

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web18863

  • via runawfe by coelho79
    , 1 year ago
    org/jbpm/graph/def/ProcessDefinition
  • org/graphstream/graph/Graph
  • via Stack Overflow by Ankita Mehta
    , 10 months ago
    org/graphstream/graph/Graph
  • Stack trace

    • java.lang.NoClassDefFoundError: org/jbpm/graph/def/ProcessDefinition at ru.runa.wf.presentation.ProcessDefinitionClassPresentation.<init>(ProcessDefinitionClassPresentation.java:52) at ru.runa.wf.presentation.ProcessDefinitionClassPresentation.<clinit>(ProcessDefinitionClassPresentation.java:49) at ru.runa.wf.presentation.WFClassPresentationFinder.<clinit>(WFClassPresentationFinder.java:37) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:169) at ru.runa.af.presentation.ClassPresentationFinderFactory.createClassPresentationFinderInstance(ClassPresentationFinderFactory.java:38) at ru.runa.af.presentation.ClassPresentationFinderFactory.getClassPresentationFinder(ClassPresentationFinderFactory.java:31) at ru.runa.af.presentation.DefaultBatchPresentationFactory.getClassPresentation(DefaultBatchPresentationFactory.java:69) at ru.runa.af.presentation.DefaultBatchPresentationFactory.<init>(DefaultBatchPresentationFactory.java:47) at ru.runa.af.presentation.AFProfileStrategy.<clinit>(AFProfileStrategy.java:35) at org.extremo.remote.AceptTaskProcess.getTasks(AceptTaskProcess.java:21) at org.extremo.remote.ProcessControl.AceptTaskProcess(ProcessControl.java:16) at org.extremo.remote.ProcessControl.main(ProcessControl.java:22) Caused by: java.lang.ClassNotFoundException: org.jbpm.graph.def.ProcessDefinition at java.net.URLClassLoader$1.run(URLClassLoader.java:200) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:188) at java.lang.ClassLoader.loadClass(ClassLoader.java:307) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301) at java.lang.ClassLoader.loadClass(ClassLoader.java:252) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    Unknown user
    Once, 1 year ago
    1195 more bugmates