java.lang.RuntimeException

There are no available Samebug tips for this exception. Do you have an idea how to solve this issue? A short tip would help users who saw this issue last week.

  • GitHub comment 47#235182513
    via GitHub by Pablocgdev
    ,
  • GitHub comment 47#235825921
    via GitHub by Pablocgdev
    ,
    • java.lang.RuntimeException: AttachProvider.providers() failed to return any provider. Tool classloader: java.net.FactoryURLClassLo ader@794104ca at org.evosuite.runtime.agent.AgentLoader.attachAgent(AgentLoader.java:122)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.runtime.agent.AgentLoader.loadAgent(AgentLoader.java:89)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.runtime.agent.InstrumentingAgent.initialize(InstrumentingAgent.java:101)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.runtime.EvoRunner.getClass(EvoRunner.java:102)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.runtime.EvoRunner.<init>(EvoRunner.java:77)[evosuite4.jar:1.0.4-alpha2] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)[na:1.8.0_91] at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)[na:1.8.0_91] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)[na:1.8.0_91] at java.lang.reflect.Constructor.newInstance(Unknown Source)[na:1.8.0_91] at org.junit.internal.builders.AnnotatedBuilder.buildRunner(AnnotatedBuilder.java:104)[evosuite4.jar:1.0.4-alpha2] at org.junit.internal.builders.AnnotatedBuilder.runnerForClass(AnnotatedBuilder.java:86)[evosuite4.jar:1.0.4-alpha2] at org.junit.runners.model.RunnerBuilder.safeRunnerForClass(RunnerBuilder.java:59)[evosuite4.jar:1.0.4-alpha2] at org.junit.internal.builders.AllDefaultPossibilitiesBuilder.runnerForClass(AllDefaultPossibilitiesBuilder.java:26)[evosuite4.jar:1.0.4-alpha2] at org.junit.runner.Computer.getRunner(Computer.java:40)[evosuite4.jar:1.0.4-alpha2] at org.junit.runner.Computer$1.runnerForClass(Computer.java:31)[evosuite4.jar:1.0.4-alpha2] at org.junit.runners.model.RunnerBuilder.safeRunnerForClass(RunnerBuilder.java:59)[evosuite4.jar:1.0.4-alpha2] at org.junit.runners.model.RunnerBuilder.runners(RunnerBuilder.java:101)[evosuite4.jar:1.0.4-alpha2] at org.junit.runners.model.RunnerBuilder.runners(RunnerBuilder.java:87)[evosuite4.jar:1.0.4-alpha2] at org.junit.runners.Suite.<init>(Suite.java:81)[evosuite4.jar:1.0.4-alpha2] at org.junit.runner.Computer.getSuite(Computer.java:28)[evosuite4.jar:1.0.4-alpha2] at org.junit.runner.Request.classes(Request.java:75)[evosuite4.jar:1.0.4-alpha2] at org.junit.runner.JUnitCore.run(JUnitCore.java:105)[evosuite4.jar:1.0.4-alpha2] at org.junit.runner.JUnitCore.run(JUnitCore.java:94)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.junit.JUnitAnalyzer.runJUnitOnCurrentProcess(JUnitAnalyzer.java:298)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.junit.JUnitAnalyzer.runTests(JUnitAnalyzer.java:267)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.junit.JUnitAnalyzer.handleTestsThatAreUnstable(JUnitAnalyzer.java:176)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.TestSuiteGenerator.compileAndCheckTests(TestSuiteGenerator.java:552)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.TestSuiteGenerator.postProcessTests(TestSuiteGenerator.java:495)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.TestSuiteGenerator.generateTestSuite(TestSuiteGenerator.java:195)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.rmi.service.ClientNodeImpl$1.run(ClientNodeImpl.java:145)[evosuite4.jar:1.0.4-alpha2] at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)[na:1.8.0_91] at java.util.concurrent.FutureTask.run(Unknown Source)[na:1.8.0_91] at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)[na:1.8.0_91] at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)[na:1.8.0_91] at java.lang.Thread.run(Unknown Source)[na:1.8.0_91]
    No Bugmate found.