java.lang.NoClassDefFoundError: org/springframework/util/ObjectUtils

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

You might've forgot to add a dependency or it's written wrong. Also, you might be using incompatible versions of Java and Hibernate. More on this here: https://goo.gl/SjSlRA

,
Expert tip

This error means there's a class missing in your classpath during runtime. You need to create a jar with all your dependencies and have it in your classpath. Check Maven Assembly Plugin and how to add your dependencies to a jar: https://goo.gl/U2zr8k

Solutions on the web

via jsystemtest by alexkr
, 1 year ago
org/springframework/util/ObjectUtils
java.lang.NoClassDefFoundError: org/springframework/util/ObjectUtils
at java.net.URLClassLoader$1.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at jsystem.framework.scenario.Parameter.setValue(Parameter.java:184)
at jsystem.framework.scenario.RunnerTest.loadParameters(RunnerTest.java:1222)
at jsystem.framework.scenario.RunnerTest.loadParametersAndValues(RunnerTest.java:698)
at jsystem.framework.scenario.RunnerTest.loadParametersAndValuesAndUpdateTestClass(RunnerTest.java:736)
at jsystem.framework.scenario.ParametersManager.loadTestParametersFromEnvironment(ParametersManager.java:277)
at jsystem.framework.scenario.ParametersManager.initTestParameters(ParametersManager.java:145)
at junit.framework.SystemTestCaseImpl.jsystemTestPreExecution(SystemTestCaseImpl.java:251)
at junit.framework.SystemTestCase.jsystemTestPreExecution(SystemTestCase.java:363)
at junit.framework.SystemTestCase.runBare(SystemTestCase.java:163)
at junit.framework.TestResult$1.protect(TestResult.java:110)
at junit.framework.TestResult.runProtected(TestResult.java:128)
at junit.framework.TestResult.run(TestResult.java:113)
at junit.framework.SystemTestCase.run(SystemTestCase.java:152)
at junit.framework.TestSuite.runTest(TestSuite.java:232)
at junit.framework.TestSuite.run(TestSuite.java:227)
at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
1219 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.