java.io.IOException

Cannot run program "C:/Program Files/Java/jdk1.6.0\bin\java " (in directory "C:\Sun\AppServer\domains\domain1\config"): CreateProcess error= 193, %1 is not a valid Win32 application

Samebug tips1

This is a bug in some versions of the Arduino IDE. Try updating to the version 1.6.12 or further.


rafaelrafael

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web2004

  • via Unknown by 807581,
  • via Unknown by laredotornado,
  • Stack trace

    • java.io.IOException: Cannot run program "C:/Program Files/Java/jdk1.6.0\bin\java " (in directory "C:\Sun\AppServer\domains\domain1\config"): CreateProcess error= 193, %1 is not a valid Win32 application at java.lang.ProcessBuilder.start(ProcessBuilder.java:459) at com.sun.enterprise.admin.servermgmt.launch.ASLauncher.executeBackgroundCommand(ASLauncher.java:573) at com.sun.enterprise.admin.servermgmt.launch.ASLauncher.executeCommand(ASLauncher.java:468) at com.sun.enterprise.admin.servermgmt.launch.ASLauncher.process(ASLauncher.java:433) at com.sun.enterprise.admin.servermgmt.pe.PEInstancesManager.startInstanceAllJava(PEInstancesManager.java:283) at com.sun.enterprise.admin.servermgmt.pe.PEInstancesManager.startInstance(PEInstancesManager.java:160) at com.sun.enterprise.ee.admin.servermgmt.EEDomainsManager.startDomain(EEDomainsManager.java:471) at com.sun.enterprise.cli.commands.StartDomainCommand.startDomain(StartDomainCommand.java:148) at com.sun.enterprise.cli.commands.StartDomainCommand.runCommand(StartDomainCommand.java:215) at com.sun.enterprise.cli.framework.CLIMain.invokeCommand(CLIMain.java:171) at com.sun.enterprise.cli.framework.CLIMain.main(CLIMain.java:79) Caused by: java.io.IOException: CreateProcess error=193, %1 is not a valid Win32 application at java.lang.ProcessImpl.create(Native Method) at java.lang.ProcessImpl.<init>(ProcessImpl.java:81) at java.lang.ProcessImpl.start(ProcessImpl.java:30) at java.lang.ProcessBuilder.start(ProcessBuilder.java:452) ... 10 more

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    SacchiSacchi
    8 times, last one
    guizmaiiguizmaii
    5 times, last one
    gpgekkogpgekko
    3 times, last one
    Unknown UserUnknown User
    Once,
    zbalintzbalint
    16 times, last one
    161 more bugmates