org.bson.codecs.configuration.CodecConfigurationException: Can't find a codec for class java.util.Arrays$ArrayList.

JIRA | Jochen Kemnade | 1 year ago
  1. 0
    Current Spark-Mongodb does not support 3.x mongo drivers. Use long instead of Date until it is upgraded.
  2. Speed up your debug routine!

    Automated exception search integrated into your IDE

  1. silex 1 times, last 7 months ago
1 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. org.bson.codecs.configuration.CodecConfigurationException

    Can't find a codec for class java.util.Arrays$ArrayList.

    at org.bson.codecs.configuration.CodecCache.getOrThrow()
  2. MongoDB Java Driver
    ProvidersCodecRegistry.get
    1. org.bson.codecs.configuration.CodecCache.getOrThrow(CodecCache.java:46)[mongo-java-driver-3.1.0.jar:na]
    2. org.bson.codecs.configuration.ProvidersCodecRegistry.get(ProvidersCodecRegistry.java:63)[mongo-java-driver-3.1.0.jar:na]
    3. org.bson.codecs.configuration.ProvidersCodecRegistry.get(ProvidersCodecRegistry.java:37)[mongo-java-driver-3.1.0.jar:na]
    3 frames
  3. Unknown
    $CodecRegistry_2952b5e77739.get
    1. $CodecRegistry_2952b5e77739.get(Unknown Source)[na:na]
    1 frame
  4. MongoDB Java Driver
    MongoCollectionImpl.findOneAndUpdate
    1. com.mongodb.client.model.BuildersHelper.encodeValue(BuildersHelper.java:35)[mongo-java-driver-3.1.0.jar:na]
    2. com.mongodb.client.model.Updates$SimpleUpdate.toBsonDocument(Updates.java:442)[mongo-java-driver-3.1.0.jar:na]
    3. com.mongodb.MongoCollectionImpl.toBsonDocument(MongoCollectionImpl.java:516)[mongo-java-driver-3.1.0.jar:na]
    4. com.mongodb.MongoCollectionImpl.findOneAndUpdate(MongoCollectionImpl.java:380)[mongo-java-driver-3.1.0.jar:na]
    4 frames