java.lang.RuntimeException

Missing com.sun.tools.attach.VirtualMachine in tools.jar

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web8041

  • via GitHub by Pablocgdev
    , 11 months ago
    Missing com.sun.tools.attach.VirtualMachine in tools.jar
  • via Google Groups by dalter, 1 year ago
    No compiler found in your classpath! (you may need to add 'tools.jar')
  • via Google Groups by Sanket Gupte, 1 year ago
    No compiler found in your classpath! (you may need to add 'tools.jar')
  • Stack trace

    • java.lang.RuntimeException: Missing com.sun.tools.attach.VirtualMachine in tools.jar at org.evosuite.runtime.agent.ToolsJarLocator.validateAndGetLoader(ToolsJarLocator.java:132)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.runtime.agent.ToolsJarLocator.considerPathInProperties(ToolsJarLocator.java:113)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.runtime.agent.ToolsJarLocator.getLoaderForToolsJar(ToolsJarLocator.java:78)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.classpath.ClassPathHacker.initializeToolJar(ClassPathHacker.java:58)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.ClientProcess.initializeToolJar(ClientProcess.java:109)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.ClientProcess.run(ClientProcess.java:74)[evosuite4.jar:1.0.4-alpha2] at org.evosuite.ClientProcess.main(ClientProcess.java:203)[evosuite4.jar:1.0.4-alpha2]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.