java.lang.RuntimeException: Missing com.sun.tools.attach.VirtualMachine in tools.jar

GitHub | Pablocgdev | 8 months ago
tip
Click on the to mark the solution that helps you, Samebug will learn from it.
As a community member, you’ll be rewarded for you help.
  1. 0

    GitHub comment 47#235174864

    GitHub | 8 months ago | Pablocgdev
    java.lang.RuntimeException: Missing com.sun.tools.attach.VirtualMachine in tools.jar

    Root Cause Analysis

    1. java.lang.RuntimeException

      Missing com.sun.tools.attach.VirtualMachine in tools.jar

      at org.evosuite.runtime.agent.ToolsJarLocator.validateAndGetLoader()
    2. org.evosuite.runtime
      ToolsJarLocator.getLoaderForToolsJar
      1. org.evosuite.runtime.agent.ToolsJarLocator.validateAndGetLoader(ToolsJarLocator.java:132)[evosuite4.jar:1.0.4-alpha2]
      2. org.evosuite.runtime.agent.ToolsJarLocator.considerPathInProperties(ToolsJarLocator.java:113)[evosuite4.jar:1.0.4-alpha2]
      3. org.evosuite.runtime.agent.ToolsJarLocator.getLoaderForToolsJar(ToolsJarLocator.java:78)[evosuite4.jar:1.0.4-alpha2]
      3 frames
    3. org.evosuite.classpath
      ClassPathHacker.initializeToolJar
      1. org.evosuite.classpath.ClassPathHacker.initializeToolJar(ClassPathHacker.java:58)[evosuite4.jar:1.0.4-alpha2]
      1 frame
    4. org.evosuite
      ClientProcess.main
      1. org.evosuite.ClientProcess.initializeToolJar(ClientProcess.java:109)[evosuite4.jar:1.0.4-alpha2]
      2. org.evosuite.ClientProcess.run(ClientProcess.java:74)[evosuite4.jar:1.0.4-alpha2]
      3. org.evosuite.ClientProcess.main(ClientProcess.java:203)[evosuite4.jar:1.0.4-alpha2]
      3 frames