weblogic.common.internal.VersioningError

No WebLogic packages defined in CLASSPATH [clientgen]

Samebug tips0

There are no available Samebug tips for this exception. If you know how to solve this issue, help other users by writing a short tip.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web63

  • No WebLogic packages defined in CLASSPATH [clientgen]
  • via Google Groups by Bo Min Jiang, 3 weeks ago
    No WebLogic packages defined in CLASSPATH
  • No WebLogic packages defined in CLASSPATH
  • Stack trace

    • weblogic.common.internal.VersioningError: No WebLogic packages defined in CLASSPATH [clientgen] at weblogic.common.internal.VersionInfo.<init>(VersionInfo.java:46)[clientgen] at weblogic.common.internal.VersionInfo.initialize(VersionInfo.java:127)[clientgen] at weblogic.common.internal.VersionInfo.theOne(VersionInfo.java:98)[clientgen] at weblogic.version.getBuildVersion(version.java:17)[clientgen] at weblogic.utils.compiler.CodeGenerator.buildString(CodeGenerator.java:801)[clientgen] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)[clientgen] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)[clientgen] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)[clientgen] at java.lang.reflect.Method.invoke(Method.java:324)[clientgen] at weblogic.utils.compiler.CodeGenerator.processAt(CodeGenerator.java:648)[clientgen] at weblogic.utils.compiler.CodeGenerator.parse(CodeGenerator.java:562)[clientgen] at weblogic.utils.compiler.CodeGenerator.parse(CodeGenerator.java:519)[clientgen] at weblogic.utils.compiler.CodeGenerator.generateCode(CodeGenerator.java:336)[clientgen] at weblogic.utils.compiler.CodeGenerator.generate(CodeGenerator.java:238)[clientgen] at weblogic.xml.schema.binding.internal.codegen.Compiler.generate(Compiler.java:606)[clientgen] at weblogic.xml.schema.binding.internal.codegen.Compiler.compile_descriptors(Compiler.java:332)[clientgen] at weblogic.xml.schema.binding.internal.codegen.Compiler.compile(Compiler.java:284)[clientgen] at weblogic.xml.schema.binding.internal.XSDTypeMappingBuilder.addTypesInSchemas(XSDTypeMappingBuilder.java:140)[clientgen] at weblogic.xml.schema.binding.internal.TypeMappingBuilderBase.processSchemaTypes(TypeMappingBuilderBase.java:310)[clientgen] at weblogic.webservice.tools.build.internal.Schema2JavaImpl.doTypeMapping(Schema2JavaImpl.java:297)[clientgen] at weblogic.webservice.tools.build.internal.Schema2JavaImpl.run(Schema2JavaImpl.java:187)[clientgen] at weblogic.webservice.tools.build.internal.WSDL2JavaImpl.run(WSDL2JavaImpl.java:240)[clientgen] at weblogic.webservice.tools.build.internal.ClientGenImpl.getTypeMappingFromWSDL(ClientGenImpl.java:742)[clientgen] at weblogic.webservice.tools.build.internal.ClientGenImpl.doClientGenFromWsdl(ClientGenImpl.java:415)[clientgen] at weblogic.webservice.tools.build.internal.ClientGenImpl.run(ClientGenImpl.java:343)[clientgen] at weblogic.ant.taskdefs.webservices.clientgen.ClientGenTask.doClientGen(ClientGenTask.java:352)[clientgen] at weblogic.ant.taskdefs.webservices.clientgen.ClientGenTask.execute(ClientGenTask.java:208)[clientgen] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)[clientgen] at org.apache.tools.ant.Task.perform(Task.java:364)[clientgen] at org.apache.tools.ant.Target.execute(Target.java:341)[clientgen] at org.apache.tools.ant.Target.performTasks(Target.java:369)[clientgen] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216)[clientgen] at org.apache.tools.ant.Project.executeTarget(Project.java:1185)[clientgen] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:40)[clientgen] at org.apache.tools.ant.Project.executeTargets(Project.java:1068)[clientgen] at org.apache.tools.ant.Main.runBuild(Main.java:668)[clientgen] at org.apache.tools.ant.Main.startAnt(Main.java:187)[clientgen] at org.apache.tools.ant.Main.start(Main.java:150)[clientgen] at org.apache.tools.ant.Main.main(Main.java:240)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.