com.typesafe.config.ConfigException$Missing: No configuration setting found for key 'akka.version'

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Solutions on the web

via GitHub by timodonnell
, 1 year ago
No configuration setting found for key 'akka.version'
via GitHub by timodonnell
, 1 year ago
No configuration setting found for key 'akka.version'
via GitHub by quintinali
, 9 months ago
No configuration setting found for key 'akka.version'
via GitHub by vsimko
, 1 year ago
No configuration setting found for key 'akka.version'
via Stack Overflow by user1893354
, 1 year ago
No configuration setting found for key 'akka.version'
via Stack Overflow by Pa Rö
, 1 year ago
No configuration setting found for key 'akka.version'
com.typesafe.config.ConfigException$Missing: No configuration setting found for key 'akka.version'
at com.typesafe.config.impl.SimpleConfig.findKey(SimpleConfig.java:124)
at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:145)
at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:151)
at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:159)
at com.typesafe.config.impl.SimpleConfig.find(SimpleConfig.java:164)
at akka.actor.ActorSystem$Settings.(ActorSystem.scala:169)
at akka.actor.ActorSystemImpl.(ActorSystem.scala:505)
at akka.actor.ActorSystem$.apply(ActorSystem.scala:142)
at akka.actor.ActorSystem$.apply(ActorSystem.scala:119)
at org.apache.spark.util.AkkaUtils$.org$apache$spark$util$AkkaUtils$$doCreateActorSystem(AkkaUtils.scala:121)
at org.apache.spark.util.AkkaUtils$$anonfun$1.apply(AkkaUtils.scala:53)
at org.apache.spark.util.AkkaUtils$$anonfun$1.apply(AkkaUtils.scala:52)
at org.apache.spark.util.Utils$.startServiceOnPort(Utils.scala:1979)
at org.apache.spark.util.AkkaUtils$.createActorSystem(AkkaUtils.scala:55)
at org.apache.spark.SparkEnv$.create(SparkEnv.scala:266)
at org.apache.spark.SparkEnv$.createDriverEnv(SparkEnv.scala:193)
at org.apache.spark.SparkContext.createSparkEnv(SparkContext.scala:288)
at org.apache.spark.SparkContext.(SparkContext.scala:457)
at org.hammerlab.guacamole.commands.SparkCommand.createSparkContext(SparkCommand.scala:65)
at org.hammerlab.guacamole.commands.SparkCommand.run(SparkCommand.scala:10)
at org.hammerlab.guacamole.commands.Command.run(Command.scala:46)
at org.hammerlab.guacamole.Main$.main(Main.scala:68)
at org.hammerlab.guacamole.Main.main(Main.scala)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
2 times, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 4 months ago
Samebug visitor profile picture
Unknown user
Once, 4 months ago
23 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.