java.lang.NoClassDefFoundError: org/eclipse/osgi/baseadaptor/HookConfigurator

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

,
Expert tip

org.apache.http.config.Lookup class is in httpcore-4.3.jar not in httpclient-4.3.1.jar

Solutions on the web

via Terracotta by polfish, 1 year ago
org/eclipse/osgi/baseadaptor/HookConfigurator
via pydev by jdiligence
, 1 year ago
org/python/core/PyObject
via Coderanch by Sathees sam, 11 months ago
org/apache/xmlbeans/XmlObject
via Coderanch by Helen Hatzi, 11 months ago
org/apache/catalina/session/StandardManager
via coderanch.com by Unknown author, 2 years ago
via xplanner by humancell
, 1 year ago
org/jfree/ui/Drawable
java.lang.NoClassDefFoundError: org/eclipse/osgi/baseadaptor/HookConfigurator
at java.lang.ClassLoader.findBootstrapClass(Native Method)
at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:892)
at java.lang.ClassLoader.loadClass(ClassLoader.java:302)
at java.lang.ClassLoader.loadClass(ClassLoader.java:300)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:169)
at org.eclipse.osgi.baseadaptor.HookRegistry.loadConfigurators(HookRegistry.java:176)
at org.eclipse.osgi.baseadaptor.HookRegistry.initialize(HookRegistry.java:100)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
at org.eclipse.core.runtime.adaptor.EclipseStarter.createAdaptor(EclipseStarter.java:751)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:282)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)

Users with the same issue

3 times, 11 months ago
2 times, 2 months ago
Samebug visitor profile picture
Unknown user
Once, 1 year ago
31 times, 2 months ago
Samebug visitor profile picture
Unknown user
Once, 3 months ago
67 more bugmates

Know the solutions? Share your knowledge to help other developers to debug faster.