java.io.FileNotFoundException

/opt/sonatype/nexus/etc/org.apache.karaf.command.acl.jaas.cfg (Permission denied)

Samebug tips0

We couldn't find tips for this exception.

Don't give up yet. Paste your full stack trace to get a solution.

Solutions on the web2106

  • via Unknown by Joe Tom,
  • via GitHub by rcarmich
    ,
  • Stack trace

    • java.io.FileNotFoundException: /opt/sonatype
    • exus/etc/org.apache.karaf.command.acl.jaas.cfg (Permission denied) at java.io.FileOutputStream.open0(Native Method)[na:1.8.0_77] at java.io.FileOutputStream.open(FileOutputStream.java:270)[na:1.8.0_77] at java.io.FileOutputStream.<init>(FileOutputStream.java:213)[na:1.8.0_77] at java.io.FileOutputStream.<init>(FileOutputStream.java:162)[na:1.8.0_77] at org.apache.felix.utils.properties.Properties.save(Properties.java:152)[org.apache.karaf.features.core:4.0.4] at org.apache.felix.utils.properties.Properties.save(Properties.java:148)[org.apache.karaf.features.core:4.0.4] at org.apache.karaf.features.internal.service.FeatureConfigInstaller.updateStorage(FeatureConfigInstaller.java:292)[org.apache.karaf.features.core:4.0.4] at org.apache.karaf.features.internal.service.FeatureConfigInstaller.installFeatureConfigs(FeatureConfigInstaller.java:107)[org.apache.karaf.features.core:4.0.4] at org.apache.karaf.features.internal.service.FeaturesServiceImpl.installFeature(FeaturesServiceImpl.java:1166)[org.apache.karaf.features.core:4.0.4] at org.apache.karaf.features.internal.service.Deployer.deploy(Deployer.java:778)[org.apache.karaf.features.core:4.0.4] at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(FeaturesServiceImpl.java:1089)[org.apache.karaf.features.core:4.0.4] at org.apache.karaf.features.internal.service.FeaturesServiceImpl$1.call(FeaturesServiceImpl.java:985)[org.apache.karaf.features.core:4.0.4] at java.util.concurrent.FutureTask.run(FutureTask.java:266)[na:1.8.0_77] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)[na:1.8.0_77] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)[na:1.8.0_77] at java.lang.Thread.run(Thread.java:745)[na:1.8.0_77]

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    PilleoPilleo
    2 times, last one
    MattyMatty
    Once,
    Unknown visitor
    Unknown visitorOnce,
    AxeloAxelo
    2 times, last one
    Unknown visitor
    Unknown visitorOnce,
    166 more bugmates