java.lang.NoClassDefFoundError

tip

org.apache.http.config.Lookup class is in httpcore-4.3.jar not in httpclient-4.3.1.jar

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    • java.lang.NoClassDefFoundError: weblogic/security/providers/authentication/MyUse rNameMapper (wrong name: MyUserNameMapper) at java.lang.ClassLoader.defineClass0(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:502) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) at java.net.URLClassLoader.defineClass(URLClassLoader.java:250) at java.net.URLClassLoader.access$100(URLClassLoader.java:54) at java.net.URLClassLoader$1.run(URLClassLoader.java:193) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:186) at java.lang.ClassLoader.loadClass(ClassLoader.java:299) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:265) at java.lang.ClassLoader.loadClass(ClassLoader.java:292) at java.lang.ClassLoader.loadClass(ClassLoader.java:255) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:315) at java.lang.Class.forName0(Native Method) at java.lang.Class.forName(Class.java:140) at weblogic.security.providers.authentication.DefaultIdentityAsserterProviderImpl.initialize(DefaultIdentityAsserterProviderImpl.java:115) at weblogic.security.service.SecurityServiceManager.createSecurityProvider(SecurityServiceManager.java:1696) at weblogic.security.service.PrincipalAuthenticator.initialize(PrincipalAuthenticator.java:158) at weblogic.security.service.PrincipalAuthenticator.<init>(PrincipalAuthenticator.java:260) at weblogic.security.service.SecurityServiceManager.doATN(SecurityServiceManager.java:1481) at weblogic.security.service.SecurityServiceManager.initializeRealm(SecurityServiceManager.java:1282) at weblogic.security.service.SecurityServiceManager.loadRealm(SecurityServiceManager.java:1216) at weblogic.security.service.SecurityServiceManager.initializeRealms(SecurityServiceManager.java:1338) at weblogic.security.service.SecurityServiceManager.initialize(SecurityServiceManager.java:1018) at weblogic.t3.srvr.T3Srvr.initializeHere(T3Srvr.java:783) at weblogic.t3.srvr.T3Srvr.initialize(T3Srvr.java:627) at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:337) at weblogic.Server.main(Server.java:32)

    Users with the same issue

    Unknown visitor1 times, last one,
    pulse00
    6 times, last one,
    guizmaii
    2 times, last one,
    andyglick
    1 times, last one,
    serious2monkeys
    60 times, last one,
    58 more bugmates