java.lang.NoClassDefFoundError

Could not initialize class com.ibm.ws.ffdc.FFDCFilter

Samebug tips1

Update your eclipse.ini file and add this to it:

-vm <path to ibm jre>\bin\javaw.exe

Don't give up yet. Our experts can help. Paste your full stack trace to get a solution.

Solutions on the web5306

  • via Unknown by rafael, 5 months ago
    The owner protected this stack trace.
  • Could not initialize class com.ibm.ws.ffdc.FFDCFilter
  • Could not initialize class com.ibm.ws.ffdc.FFDCFilter
  • Stack trace

    • java.lang.NoClassDefFoundError: Could not initialize class com.ibm.ws.ffdc.FFDCFilter at com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplateOnce(SOAPConnectorClient.java:870) at com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplate(SOAPConnectorClient.java:689) at com.ibm.ws.management.connector.soap.SOAPConnectorClient.invokeTemplate(SOAPConnectorClient.java:679) at com.ibm.ws.management.connector.soap.SOAPConnectorClient.isAlive(SOAPConnectorClient.java:573) at com.ibm.ws.management.connector.soap.SOAPConnectorClient.invoke(SOAPConnectorClient.java:503) at com.sun.proxy.$Proxy38.isAlive(Unknown Source) at com.ibm.ws.management.AdminClientImpl.isAlive(AdminClientImpl.java:103) at com.ibm.ws.ast.st.jmx.core.internal.WebSphereGenericJmxConnection.isConnectionAlive(WebSphereGenericJmxConnection.java:800) at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.getWebSphereJmxConnection(WASServerBehaviour.java:1105) at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.getJmxConnection(WASServerBehaviour.java:1071) at com.ibm.ws.ast.st.common.core.internal.AbstractWASServerBehaviour.ensureJmxConnection(AbstractWASServerBehaviour.java:546) at com.ibm.ws.ast.st.v8.core.internal.WASServerBehaviour.start(WASServerBehaviour.java:2895) at com.ibm.ws.ast.st.v8.core.internal.WASLaunchConfigurationDelegate.launch(WASLaunchConfigurationDelegate.java:258) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:885) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:739) at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:731) at org.eclipse.wst.server.core.internal.Server.startImpl2(Server.java:3556) at org.eclipse.wst.server.core.internal.Server.startImpl(Server.java:3492) at org.eclipse.wst.server.core.internal.Server$StartJob.run(Server.java:367) at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

    Write tip

    You have a different solution? A short tip here would help you and many other users who saw this issue last week.

    Users with the same issue

    You’re the first here who have seen this exception.