java.lang.UnsupportedClassVersionError: org/eclipse/emf/ecore/resource/Resource$Factory$Registry (Unsupported major.minor version 49.0)

Coderanch | Mark Curlette | 4 years ago
  1. 0

    Question on java.lang.UnsupportedClassVersionError

    Coderanch | 4 years ago | Mark Curlette
    java.lang.UnsupportedClassVersionError: org/eclipse/emf/ecore/resource/Resource$Factory$Registry (Unsupported major.minor version 49.0)
  2. 0

    Unsupported Java major.minor version 51.0 w/ OS X 10.10 Yosemite

    GitHub | 2 years ago | takahiro47
    java.lang.UnsupportedClassVersionError: org/elasticsearch/bootstrap/Elasticsearch : Unsupported major.minor version 51.0
  3. 0

    Unsupported major.minor version 52.0

    GitHub | 1 year ago | humandb
    java.lang.UnsupportedClassVersionError: com/typesafe/config/ConfigFactory : Unsupported major.minor version 52.0
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    Tagging text with Stanford POS Tagger in Java Applications | Galal Aly

    galalaly.me | 1 year ago
    java.lang.UnsupportedClassVersionError: edu/stanford/nlp/tagger/maxent/MaxentTagger : Unsupported major.minor version 52.0
  6. 0

    java unit test failure in regression ; major version 51 is newer than 50, the highest major version supported by this compiler.

    GitHub | 2 years ago | gghai
    org.springframework.beans.factory.CannotLoadBeanClassException: Error loading class [com.marklogic.samplestack.web.security.SamplestackSecurityFilters] for bean with name 'samplestackSecurityFilters' defined in file [/space/builder/builds/macosx-64/HEAD/qa/marklogic-samplestack/appserver/java-spring/build/classes/main/com/marklogic/samplestack/web/security/SamplestackSecurityFilters.class]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: javax/servlet/Filter : Unsupported major.minor version 51.0

  1. harshg 4 times, last 3 months ago
  2. muffinmannen 1 times, last 5 months ago
  3. bpbhat77 1 times, last 5 months ago
  4. Akhilesh Patel 2 times, last 1 year ago
56 unregistered visitors
Not finding the right solution?
Take a tour to get the most out of Samebug.

Tired of useless tips?

Automated exception search integrated into your IDE

Root Cause Analysis

  1. java.lang.UnsupportedClassVersionError

    org/eclipse/emf/ecore/resource/Resource$Factory$Registry (Unsupported major.minor version 49.0)

    at java.lang.ClassLoader.defineClass0()
  2. Java RT
    ClassLoader.loadClass
    1. java.lang.ClassLoader.defineClass0(Native Method)
    2. java.lang.ClassLoader.defineClass(ClassLoader.java:810)
    3. java.security.SecureClassLoader.defineClass(SecureClassLoader.java:147)
    4. java.net.URLClassLoader.defineClass(URLClassLoader.java:475)
    5. java.net.URLClassLoader.access$500(URLClassLoader.java:109)
    6. java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:848)
    7. java.security.AccessController.doPrivileged1(Native Method)
    8. java.security.AccessController.doPrivileged(AccessController.java:389)
    9. java.net.URLClassLoader.findClass(URLClassLoader.java:371)
    10. java.lang.ClassLoader.loadClass(ClassLoader.java:572)
    11. sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:442)
    12. java.lang.ClassLoader.loadClass(ClassLoader.java:504)
    12 frames