java.net.SocketException

tip

Nginx does not handle websocket requests. Configure nginx proxy for websockets.

tip

Upgrade your docker-selenium

tip

Client closed the websocket connection (safe to ignore)

tip

*not english*


poroszd
tip

It takes too long time for the JVM to find enough entropy for secure connection. Use this jvm option: '-Djava.security.egd=file:/dev/./urandom'.

tip

Upgrade yokozuna

tip

Set larger socket timeout (or 0 to set no timeout).

tip

Upgrade your nanohttpd

tip

Here is a animation for the life cycle. http://tcp.cs.st-andrews.ac.uk/index.shtml?page=connection_lifecycle

tip

Probably there is a bug in TestNG Eclipse plugin (6.8.6.20130607_0745), try an other version (e.g. 6.8.0.20121120_1820)

tip

before running my test in debug mode, i open the debug view, and remove some breakpoints (such as some remaining on NullPointersExceptions, and Sockets)

tip

Try removing all the breakpoints (even if breakpoints are disabled the problem still occurs, yes even if both disabled entirely and piecewise).

tip

There is a known issue between TestNG 6.4 and IDEA, the next EAP will fix this but in the meantime, use the previous version.

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Looks like the hack in menu.css could have side efects... Using a plain page, got this one when rendering in IE6: {noformat} Apr 19, 2008 9:14:41 AM org.apache.catalina.core.StandardHostValve status WARNING: Exception Processing ErrorPage[errorCode=404, location=/fourohfour.action] ClientAbortException: java.net.SocketException: Broken pipe at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:327) at org.apache.catalina.connector.OutputBuffer.flush(OutputBuffer.java:293) at org.apache.catalina.connector.Response.flushBuffer(Response.java:539) at org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:287) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870) at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665) at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528) at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685) at java.lang.Thread.run(Thread.java:613) Caused by: java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92) at java.net.SocketOutputStream.write(SocketOutputStream.java:136) at org.apache.coyote.http11.InternalOutputBuffer.realWriteBytes(InternalOutputBuffer.java:747) at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:432) at org.apache.coyote.http11.InternalOutputBuffer.flush(InternalOutputBuffer.java:305) at org.apache.coyote.http11.Http11Processor.action(Http11Processor.java:992) at org.apache.coyote.Response.action(Response.java:183) at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:322) ... 13 more {noformat} Sometimes there are more. Thing is that IE6 make several requests: {noformat} 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /display/EMPTY/Home HTTP/1.1" 200 21643 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/3/_/styles/combined.css?spaceKey=EMPTY HTTP/1.1" 200 314 "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/3/_/styles/colors.css?spaceKey=EMPTY HTTP/1.1" 200 5849 "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" {noformat} Many requests to a non existing image is going to invoke the {{fourofour.action}} just for free. Now, imagine the multiple requests made by IE6...
    via by Roberto Dominguez,
  • Looks like the hack in menu.css could have side efects... Using a plain page, got this one when rendering in IE6: {noformat} Apr 19, 2008 9:14:41 AM org.apache.catalina.core.StandardHostValve status WARNING: Exception Processing ErrorPage[errorCode=404, location=/fourohfour.action] ClientAbortException: java.net.SocketException: Broken pipe at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:327) at org.apache.catalina.connector.OutputBuffer.flush(OutputBuffer.java:293) at org.apache.catalina.connector.Response.flushBuffer(Response.java:539) at org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:287) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870) at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665) at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528) at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685) at java.lang.Thread.run(Thread.java:613) Caused by: java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92) at java.net.SocketOutputStream.write(SocketOutputStream.java:136) at org.apache.coyote.http11.InternalOutputBuffer.realWriteBytes(InternalOutputBuffer.java:747) at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:432) at org.apache.coyote.http11.InternalOutputBuffer.flush(InternalOutputBuffer.java:305) at org.apache.coyote.http11.Http11Processor.action(Http11Processor.java:992) at org.apache.coyote.Response.action(Response.java:183) at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:322) ... 13 more {noformat} Sometimes there are more. Thing is that IE6 make several requests: {noformat} 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /display/EMPTY/Home HTTP/1.1" 200 21643 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/3/_/styles/combined.css?spaceKey=EMPTY HTTP/1.1" 200 314 "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/3/_/styles/colors.css?spaceKey=EMPTY HTTP/1.1" 200 5849 "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" 192.168.0.150 - - [19/Apr/2008:09:14:41 -0700] "GET /s/1318/1/1.0/_/images/icons/fake.gif HTTP/1.1" 404 - "http://tepoztlan:20280/display/EMPTY/Home" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)" {noformat} Many requests to a non existing image is going to invoke the {{fourofour.action}} just for free. Now, imagine the multiple requests made by IE6...
    via by Roberto Dominguez,
  • Broken Pipe - Jboss 4.0.4 - Roller 3.0
    via by Steve Wells,
  • Re: Broken Pipe - Jboss 4.0.4 - Roller 3.0
    via by Steve Wells,
    • java.net.SocketException: Broken pipe at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:327) at org.apache.catalina.connector.OutputBuffer.flush(OutputBuffer.java:293) at org.apache.catalina.connector.Response.flushBuffer(Response.java:539) at org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:287) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108) at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151) at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870) at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665) at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528) at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685) at java.lang.Thread.run(Thread.java:613) Caused by: java.net.SocketException: Broken pipe at java.net.SocketOutputStream.socketWrite0(Native Method) at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:92) at java.net.SocketOutputStream.write(SocketOutputStream.java:136) at org.apache.coyote.http11.InternalOutputBuffer.realWriteBytes(InternalOutputBuffer.java:747) at org.apache.tomcat.util.buf.ByteChunk.flushBuffer(ByteChunk.java:432) at org.apache.coyote.http11.InternalOutputBuffer.flush(InternalOutputBuffer.java:305) at org.apache.coyote.http11.Http11Processor.action(Http11Processor.java:992) at org.apache.coyote.Response.action(Response.java:183) at org.apache.catalina.connector.OutputBuffer.doFlush(OutputBuffer.java:322) ... 13 more

    Users with the same issue

    Unknown visitor1 times, last one,
    linxiaolong
    3 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor2 times, last one,
    Unknown visitor1 times, last one,
    226 more bugmates