java.lang.InternalError: Can't connect to X11 window server using 'dev14:0.0' as the value of the DISPLAY variable.

Searched on Google with the first line of a JAVA stack trace?

We can recommend more relevant solutions and speed up debugging when you paste your entire stack trace with the exception message. Try a sample exception.

Recommended solutions based on your search

Samebug tips

Do you know how to solve this issue? Write a tip to help other users and build your expert profile.

Solutions on the web

via linuxquestions.org by Unknown author, 1 year ago
Can't connect to X11 window server using 'dev14:0.0' as the value of the DISPLAY variable.
via experts-exchange.com by Unknown author, 1 year ago
Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
via Oracle Community by user289820, 5 months ago
Can't connect to X11 window server using ':1.0' as the value of the DISPLAY variable.
via Google Groups by Ryan Whitney (JIRA), 1 year ago
Can't connect to X11 window server using 'localhost:10.0' as the value of the DISPLAY variable.
via Oracle Community by Tamim Khan, 3 months ago
Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
via Oracle Community by Tamim Khan, 1 year ago
Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
java.lang.InternalError: Can't connect to X11 window server using 'dev14:0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.access$000(X11GraphicsEnvironment.java:53)
at sun.awt.X11GraphicsEnvironment$1.run(X11GraphicsEnvironment.java:142)
at java.security.AccessController.doPrivileged(Native Method)
at sun.awt.X11GraphicsEnvironment.(X11GraphicsEnvironment.java:131)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:164)
at sun.awt.X11.XToolkit.(XToolkit.java:96)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:164)
at java.awt.Toolkit$2.run(Toolkit.java:821)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:804)
at javax.swing.UIManager.initialize(UIManager.java:1262)
at javax.swing.UIManager.maybeInitialize(UIManager.java:1245)
at javax.swing.UIManager.getDefaults(UIManager.java:556)
at org.openide.filesystems.FileUtil.(FileUtil.java:49)
at org.netbeans.core.NonGui.getUserDir(NonGui.java:118)
at org.netbeans.core.NonGui.getLogDir(NonGui.java:147)
at org.netbeans.core.CLIOptions.initialize(CLIOptions.java:192)
at org.netbeans.core.Main.start(Main.java:304)
at org.netbeans.core.TopThreadGroup.run(TopThreadGroup.java:90)
at java.lang.Thread.run(Thread.java:595)

Users with the same issue

Samebug visitor profile picture
Unknown user
Once, 1 year ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago
Samebug visitor profile picture
Unknown user
Once, 2 years ago

Write tip

Know the solutions? Share your knowledge to help other developers to debug faster.