sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process

Java.net JIRA | robertkuhar | 4 years ago
  1. 0

    Not able to connect to Tomcat via jconsole

    tomcat-users | 3 years ago | Christopher Schultz
    sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process
  2. 0

    VisualVM no longer locates local JVM PIDs in the presence of Eclipse Juno. If eclipse isn't running, VisualVM launches without issue and I see all the PIDs of the local JVMs under the Local tag on the tree. If eclipse is running, I almost always (but not always always) get to see no JVMs by Pid other than VisualVM itself. This happens both with the 1.5.3 VisualVM I launch from the Dock and an VisualVM launched from a command line via jvisualvm command. There is an unsettling stacktrace in the logfile from "About VisualVM": INFO [com.sun.tools.visualvm.attach.AttachModelImpl]: getSystemProperties com.sun.tools.attach.AttachNotSupportedException: Unable to open socket file: target process not responding or HotSpot VM not loaded at sun.tools.attach.BsdVirtualMachine.<init>(BsdVirtualMachine.java:90) at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:63) at com.sun.tools.attach.VirtualMachine.attach(VirtualMachine.java:213) at com.sun.tools.visualvm.attach.AttachModelImpl.getVirtualMachine(AttachModelImpl.java:124) Caused: java.io.IOException: Unable to open socket file: target process not responding or HotSpot VM not loaded at com.sun.tools.visualvm.attach.AttachModelImpl.getVirtualMachine(AttachModelImpl.java:126) [catch] at com.sun.tools.visualvm.attach.AttachModelImpl.getSystemProperties(AttachModelImpl.java:56) at com.sun.tools.visualvm.jvm.JVMImpl.getSystemProperties(JVMImpl.java:294) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:75) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) INFO [com.sun.tools.visualvm.jmx.impl.JmxModelImpl]: connect(2344) com.sun.tools.attach.AttachNotSupportedException: Unable to open socket file: target process not responding or HotSpot VM not loaded at sun.tools.attach.BsdVirtualMachine.<init>(BsdVirtualMachine.java:90) at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:63) at com.sun.tools.attach.VirtualMachine.attach(VirtualMachine.java:213) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$LocalVirtualMachine.loadManagementAgent(JmxModelImpl.java:673) Caused: java.io.IOException: Unable to open socket file: target process not responding or HotSpot VM not loaded at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$LocalVirtualMachine.loadManagementAgent(JmxModelImpl.java:675) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$LocalVirtualMachine.startManagementAgent(JmxModelImpl.java:653) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$ProxyClient.tryConnect(JmxModelImpl.java:470) [catch] at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$ProxyClient.connect(JmxModelImpl.java:440) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl.connect(JmxModelImpl.java:220) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl.<init>(JmxModelImpl.java:190) at com.sun.tools.visualvm.jmx.impl.JmxModelProvider.createModelFor(JmxModelProvider.java:65) at com.sun.tools.visualvm.jmx.impl.JmxModelProvider.createModelFor(JmxModelProvider.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.tools.jmx.JmxModelFactory.getJmxModelFor(JmxModelFactory.java:69) at com.sun.tools.visualvm.jvm.JVMImpl.getJmxModel(JVMImpl.java:456) at com.sun.tools.visualvm.jvm.JVMImpl.getSystemProperties(JVMImpl.java:298) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:75) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) INFO [com.sun.tools.visualvm.sa.SaModelProvider]: Error getting SA agent sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.attach0(Native Method) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.access$100(BsdDebuggerLocal.java:51) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$1AttachTask.doit(BsdDebuggerLocal.java:261) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$BsdDebuggerLocalWorkerThread.run(BsdDebuggerLocal.java:129) Caused: sun.jvm.hotspot.debugger.DebuggerException at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$BsdDebuggerLocalWorkerThread.execute(BsdDebuggerLocal.java:154) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.attach(BsdDebuggerLocal.java:270) at sun.jvm.hotspot.HotSpotAgent.attachDebugger(HotSpotAgent.java:596) at sun.jvm.hotspot.HotSpotAgent.setupDebuggerBsd(HotSpotAgent.java:584) at sun.jvm.hotspot.HotSpotAgent.setupDebugger(HotSpotAgent.java:340) at sun.jvm.hotspot.HotSpotAgent.go(HotSpotAgent.java:313) at sun.jvm.hotspot.HotSpotAgent.attach(HotSpotAgent.java:157) Caused: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:601) at com.sun.tools.visualvm.sa.SAObject.invoke(SAObject.java:107) at com.sun.tools.visualvm.sa.Agent.attach(Agent.java:64) at com.sun.tools.visualvm.sa.SaModelImpl.attach(SaModelImpl.java:118) at com.sun.tools.visualvm.sa.SaModelImpl.readData(SaModelImpl.java:126) at com.sun.tools.visualvm.sa.SaModelImpl.<init>(SaModelImpl.java:52) [catch] at com.sun.tools.visualvm.sa.SaModelProvider.createModelFor(SaModelProvider.java:78) at com.sun.tools.visualvm.sa.SaModelProvider.createModelFor(SaModelProvider.java:46) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.tools.sa.SaModelFactory.getSAAgentFor(SaModelFactory.java:65) at com.sun.tools.visualvm.jvm.JVMImpl.getSAAgent(JVMImpl.java:452) at com.sun.tools.visualvm.jvm.JVMImpl.getSystemProperties(JVMImpl.java:305) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:75) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1 java.lang.NullPointerException at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:76) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) [catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) When I launch from the command line there is an unsettling message to stdout/stderr: bobk-mbp:~ bobk$ jvisualvm attach: task_for_pid(1877) failed (5) If there is no eclipse running, things are fine. All the competing PIDs show up. Whats up with that? I am fairly certain that this used to work prior to my upgrade of OS X to Mountain Lion from Snow Leopard and JDK 1.7 from 1.6. The eclipse version hasn't changed nor has the VisualVM version (other than the jvisualvm was rev'ed when I installed JDK 1.7).

    Java.net JIRA | 4 years ago | robertkuhar
    sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process
  3. 0

    VisualVM no longer locates local JVM PIDs in the presence of Eclipse Juno. If eclipse isn't running, VisualVM launches without issue and I see all the PIDs of the local JVMs under the Local tag on the tree. If eclipse is running, I almost always (but not always always) get to see no JVMs by Pid other than VisualVM itself. This happens both with the 1.5.3 VisualVM I launch from the Dock and an VisualVM launched from a command line via jvisualvm command. There is an unsettling stacktrace in the logfile from "About VisualVM": INFO [com.sun.tools.visualvm.attach.AttachModelImpl]: getSystemProperties com.sun.tools.attach.AttachNotSupportedException: Unable to open socket file: target process not responding or HotSpot VM not loaded at sun.tools.attach.BsdVirtualMachine.<init>(BsdVirtualMachine.java:90) at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:63) at com.sun.tools.attach.VirtualMachine.attach(VirtualMachine.java:213) at com.sun.tools.visualvm.attach.AttachModelImpl.getVirtualMachine(AttachModelImpl.java:124) Caused: java.io.IOException: Unable to open socket file: target process not responding or HotSpot VM not loaded at com.sun.tools.visualvm.attach.AttachModelImpl.getVirtualMachine(AttachModelImpl.java:126) [catch] at com.sun.tools.visualvm.attach.AttachModelImpl.getSystemProperties(AttachModelImpl.java:56) at com.sun.tools.visualvm.jvm.JVMImpl.getSystemProperties(JVMImpl.java:294) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:75) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) INFO [com.sun.tools.visualvm.jmx.impl.JmxModelImpl]: connect(2344) com.sun.tools.attach.AttachNotSupportedException: Unable to open socket file: target process not responding or HotSpot VM not loaded at sun.tools.attach.BsdVirtualMachine.<init>(BsdVirtualMachine.java:90) at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:63) at com.sun.tools.attach.VirtualMachine.attach(VirtualMachine.java:213) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$LocalVirtualMachine.loadManagementAgent(JmxModelImpl.java:673) Caused: java.io.IOException: Unable to open socket file: target process not responding or HotSpot VM not loaded at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$LocalVirtualMachine.loadManagementAgent(JmxModelImpl.java:675) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$LocalVirtualMachine.startManagementAgent(JmxModelImpl.java:653) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$ProxyClient.tryConnect(JmxModelImpl.java:470) [catch] at com.sun.tools.visualvm.jmx.impl.JmxModelImpl$ProxyClient.connect(JmxModelImpl.java:440) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl.connect(JmxModelImpl.java:220) at com.sun.tools.visualvm.jmx.impl.JmxModelImpl.<init>(JmxModelImpl.java:190) at com.sun.tools.visualvm.jmx.impl.JmxModelProvider.createModelFor(JmxModelProvider.java:65) at com.sun.tools.visualvm.jmx.impl.JmxModelProvider.createModelFor(JmxModelProvider.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.tools.jmx.JmxModelFactory.getJmxModelFor(JmxModelFactory.java:69) at com.sun.tools.visualvm.jvm.JVMImpl.getJmxModel(JVMImpl.java:456) at com.sun.tools.visualvm.jvm.JVMImpl.getSystemProperties(JVMImpl.java:298) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:75) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) INFO [com.sun.tools.visualvm.sa.SaModelProvider]: Error getting SA agent sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.attach0(Native Method) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.access$100(BsdDebuggerLocal.java:51) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$1AttachTask.doit(BsdDebuggerLocal.java:261) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$BsdDebuggerLocalWorkerThread.run(BsdDebuggerLocal.java:129) Caused: sun.jvm.hotspot.debugger.DebuggerException at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$BsdDebuggerLocalWorkerThread.execute(BsdDebuggerLocal.java:154) at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.attach(BsdDebuggerLocal.java:270) at sun.jvm.hotspot.HotSpotAgent.attachDebugger(HotSpotAgent.java:596) at sun.jvm.hotspot.HotSpotAgent.setupDebuggerBsd(HotSpotAgent.java:584) at sun.jvm.hotspot.HotSpotAgent.setupDebugger(HotSpotAgent.java:340) at sun.jvm.hotspot.HotSpotAgent.go(HotSpotAgent.java:313) at sun.jvm.hotspot.HotSpotAgent.attach(HotSpotAgent.java:157) Caused: java.lang.reflect.InvocationTargetException at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:601) at com.sun.tools.visualvm.sa.SAObject.invoke(SAObject.java:107) at com.sun.tools.visualvm.sa.Agent.attach(Agent.java:64) at com.sun.tools.visualvm.sa.SaModelImpl.attach(SaModelImpl.java:118) at com.sun.tools.visualvm.sa.SaModelImpl.readData(SaModelImpl.java:126) at com.sun.tools.visualvm.sa.SaModelImpl.<init>(SaModelImpl.java:52) [catch] at com.sun.tools.visualvm.sa.SaModelProvider.createModelFor(SaModelProvider.java:78) at com.sun.tools.visualvm.sa.SaModelProvider.createModelFor(SaModelProvider.java:46) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.tools.sa.SaModelFactory.getSAAgentFor(SaModelFactory.java:65) at com.sun.tools.visualvm.jvm.JVMImpl.getSAAgent(JVMImpl.java:452) at com.sun.tools.visualvm.jvm.JVMImpl.getSystemProperties(JVMImpl.java:305) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:75) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) SEVERE [org.openide.util.RequestProcessor]: Error in RequestProcessor com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1 java.lang.NullPointerException at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.getName(EclipseApplicationTypeFactory.java:76) at com.sun.tools.visualvm.application.type.EclipseApplicationTypeFactory.createApplicationTypeFor(EclipseApplicationTypeFactory.java:64) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:150) at com.sun.tools.visualvm.application.type.MainClassApplicationTypeFactory.createModelFor(MainClassApplicationTypeFactory.java:42) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.application.type.ApplicationTypeFactory.getApplicationTypeFor(ApplicationTypeFactory.java:74) at com.sun.tools.visualvm.application.ApplicationDescriptor.<init>(ApplicationDescriptor.java:55) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:43) at com.sun.tools.visualvm.application.ApplicationDescriptorProvider.createModelFor(ApplicationDescriptorProvider.java:38) at com.sun.tools.visualvm.core.model.ModelFactory.getModel(ModelFactory.java:111) at com.sun.tools.visualvm.core.datasource.descriptor.DataSourceDescriptorFactory.getDescriptor(DataSourceDescriptorFactory.java:69) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDisplayableDataSources(ExplorerModelBuilder.java:152) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processIndependentAddedDataSources(ExplorerModelBuilder.java:116) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.processAddedDataSources(ExplorerModelBuilder.java:105) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder.access$200(ExplorerModelBuilder.java:59) at com.sun.tools.visualvm.core.explorer.ExplorerModelBuilder$1.run(ExplorerModelBuilder.java:98) at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:1452) [catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:2032) When I launch from the command line there is an unsettling message to stdout/stderr: bobk-mbp:~ bobk$ jvisualvm attach: task_for_pid(1877) failed (5) If there is no eclipse running, things are fine. All the competing PIDs show up. Whats up with that? I am fairly certain that this used to work prior to my upgrade of OS X to Mountain Lion from Snow Leopard and JDK 1.7 from 1.6. The eclipse version hasn't changed nor has the VisualVM version (other than the jvisualvm was rev'ed when I installed JDK 1.7).

    Java.net JIRA | 4 years ago | robertkuhar
    sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process
  4. Speed up your debug routine!

    Automated exception search integrated into your IDE

  5. 0

    IDEA 13.0.2 Debug with JDK 1.70_51 on OSX 10.9.1

    GitHub | 3 years ago | nashspence
    sun.jvm.hotspot.debugger.DebuggerException: Can't attach to the process
  6. 0

    Java support for jstack

    freebsd.org | 1 month ago
    sun.jvm.hotspot.debugger.DebuggerException: get_thread_regs failed for a lwp

    Not finding the right solution?
    Take a tour to get the most out of Samebug.

    Tired of useless tips?

    Automated exception search integrated into your IDE

    Root Cause Analysis

    1. sun.jvm.hotspot.debugger.DebuggerException

      Can't attach to the process

      at sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.attach0()
    2. sun.jvm.hotspot
      BsdDebuggerLocal$BsdDebuggerLocalWorkerThread.run
      1. sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.attach0(Native Method)
      2. sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal.access$100(BsdDebuggerLocal.java:51)
      3. sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$1AttachTask.doit(BsdDebuggerLocal.java:261)
      4. sun.jvm.hotspot.debugger.bsd.BsdDebuggerLocal$BsdDebuggerLocalWorkerThread.run(BsdDebuggerLocal.java:129)
      4 frames