java.lang.NoClassDefFoundError

tip

Look if your classpath is correct, and check if the versions of your libraries match the version you described in your pom.xml

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • db:: 3.27::weblogic.kernel.Default error 99
    via by Unknown author,
  • Struts2 Hello World jsp example error
    via Stack Overflow by lulu88
    ,
  • mvn clean failing on junit tests.
    via by google_user,
  • In eclipse start tomcat error
    via Stack Overflow by Feng Ye
    ,
    • java.lang.NoClassDefFoundError: com/bea/wlw/runtime/core/bean/AsyncDispatcherBean : weblogic/ejb20/interfaces/JmsMessageDrivenBean at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:620) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124) at java.net.URLClassLoader.defineClass(URLClassLoader.java:260) at java.net.URLClassLoader.access$100(URLClassLoader.java:56) at java.net.URLClassLoader$1.run(URLClassLoader.java:195) at java.net.URLClassLoader.findClass(URLClassLoader.java:188) at java.lang.ClassLoader.loadClass(ClassLoader.java:306) at java.lang.ClassLoader.loadClass(ClassLoader.java:251)

    Users with the same issue

    junior_cEngineer
    1 times, last one,
    Unknown visitor1 times, last one,
    Unknown visitor1 times, last one,
    andyglick
    2 times, last one,
    Unknown visitor1 times, last one,
    164 more bugmates