java.net.BindException

If you like a tip written by other Samebug users, mark is as helpful! Marks help our algorithm provide you better solutions and also help other users.
tip

It might be that there's another process connecting to the same port you're trying to use, try to kill it or change the connection port.


rafaelrafael
tip

Try changing the port in core-site.xml from 9000 to 9001 as it seems port 9000 doesn't work.

tip

Change the connection port and ip adress. If you're trying to connect to your server from your own computer, check if you haven't already connected to the server in another instance.


rafaelrafael

You have a different solution? A short tip here would help you and many other users who saw this issue last week.

  • Sonar started but builds are failing
    via Stack Overflow by PT_C
    ,
  • Tomcat won't start on localhost
    via Stack Overflow by dude
    ,
  • Why Smartfoxserver 2X is not running?
    via Stack Overflow by K. Ayaz
    ,
    • java.net.BindException: Address already in use: bind at sun.nio.ch.Net.bind(Native Method) at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:108) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59) at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:52) at com.sun.enterprise.web.connector.grizzly.SelectorThread.initEndpoint(SelectorThread.java:494) at com.sun.enterprise.web.connector.grizzly.GrizzlyHttpProtocol.init(GrizzlyHttpProtocol.java:188) at org.apache.coyote.tomcat5.CoyoteConnector.initialize(CoyoteConnector.java:1415) at org.apache.catalina.startup.Embedded.start(Embedded.java:860) at com.sun.enterprise.web.WebContainer.start(WebContainer.java:673) at com.sun.enterprise.web.PEWebContainer.startInstance(PEWebContainer.java:430) at com.sun.enterprise.web.PEWebContainerLifecycle.onStartup(PEWebContainerLifecycle.java:54) at com.sun.enterprise.server.ApplicationServer.onStartup(ApplicationServer.java:300) at com.sun.enterprise.server.PEMain.run(PEMain.java:265) at com.sun.enterprise.server.PEMain.main(PEMain.java:217)

    Users with the same issue

    tomthomastomthomas
    3 times, last one,
    AxeloAxelo
    31 times, last one,
    Unknown visitor
    Unknown visitor1 times, last one,
    Victor_ITVictor_IT
    1 times, last one,
    SteVio1989SteVio1989
    1 times, last one,
    129 more bugmates