java.lang.LinkageError: Version mismatch: jar version is '23', native library version is '24'

GitHub | Blackasaurus | 4 years ago
tip
Do you know that we can give you better hits? Get more relevant results from Samebug’s stack trace search.
  1. 0

    Error with latest update

    GitHub | 4 years ago | Blackasaurus
    java.lang.LinkageError: Version mismatch: jar version is '23', native library version is '24'
  2. 0

    Unknown platform: "Darwin"

    GitHub | 6 years ago | atamis
    java.lang.LinkageError: Unknown platform: Darwin

    Root Cause Analysis

    1. java.lang.LinkageError

      Version mismatch: jar version is '23', native library version is '24'

      at org.lwjgl.Sys.<clinit>()
    2. Lighweight Java Game Library
      CL.<clinit>
      1. org.lwjgl.Sys.<clinit>(Sys.java:118)
      2. org.lwjgl.opencl.CL.<clinit>(CL.java:52)
      2 frames
    3. com.diablominer.DiabloMiner
      DiabloMiner.main
      1. com.diablominer.DiabloMiner.DeviceState.GPUHardwareType.<init>(GPUHardwareType.java:186)
      2. com.diablominer.DiabloMiner.DiabloMiner.execute(DiabloMiner.java:355)
      3. com.diablominer.DiabloMiner.DiabloMiner.main(DiabloMiner.java:90)
      3 frames